Page 1 of 20 1 2 3 11 ... LastLast
Results 1 to 10 of 197
  1. #1
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81

    Help!!! Catch Can is getting full in less than an hour...

    I just got back home from being out of town for a week on the lake. My ski has about 190 hours on it with mods listed below in my sig. The maintenance light kicked on early in the week but showed no codes, so every time i turn it on now it flashes the maintenance warning. I thought no big deal, it's just warning me for my second 100 hour service. Couple days later I'm riding and my oil light kicks on and goes into limp mode. So I popped the seat off and noticed my catch can is full of oil and starting to blow through the breather filter. I head back to shore, ski ran fine, no limp mode. Checked my oil level, it was a little low so i drained the catch can and added some oil to right in between the on the D stick. Head back out. Oil light comes back on again goes into limp mode for a few seconds then runs fine, catch can is full again of an oil and gas mixture. After this I took the ski out of the water.

    I've heard of this happening with open loop cooling but i still have the closed loop system.

    What could possibly be my problem/problems guys?


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Just wondering? What are your AFRs like with the RUDE1 and 42s with I assume a stock ECU? I would check compression.

  3. #3
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    I don't have a wideband yet, I was told by jerry to set my base fuel pressure to 60 psi and forget about it with this setup for now. Still has the stock ecu. I was thinking possibly the thermostat has gone bad and stuck open. I plan on doing a leak down test tomorrow.

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Yea, with a RUDE1 I would be worried about being on the lean side with 42s. Your RRFPR better be working correctly for sure. Can you see your fuel pressure while riding? Also, what are your RPMs at WOT?

  5. #5
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Your gonna be lean with 42s and a rude 1. I bet you broke some rings or melted pistons from deto. Time for a rebuild. Do a comp test first. Never assume your AFR is good because someone says so. Even Jerry. Many of those RRFPR only rise a few PSI even though they are suppose to be1:1. And they rise less and less as the base fuel pressure is turned up depending on your fuel pump

  6. #6
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Rpms are at 7800 with an untouched 15/20r. I have ridden with the seat off to make sure the fuel pressure was rising and it does. Before it got really hot and humid out my rpms were at 8100.

  7. #7
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Something not right anyway. You should be banging the limiter with a 15/20 and your set up.

  8. #8
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    I promise you are lean with that setup. On Phoneboys ski we had to use 48s on an x-charger to get a good AF. You have 42s on a Rude 1 which is a step above an x-xharger. Hate to be the bearer of bad news but your screwed. Do a comp test and tell us where your at. Your rings are still sealing good enough to give you decent performance but not performing good enough to keep excessive amounts of combustion gases out of the crank case

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by GOLD06RXP View Post
    I promise you are lean with that setup. On Phoneboys ski we had to use 48s on an x-charger to get a good AF. You have 42s on a Rude 1 which is a step above an x-xharger. Hate to be the bearer of bad news but your screwed. Do a comp test and tell us where your at. Your rings are still sealing good enough to give you decent performance but not performing good enough to keep excessive amounts of combustion gases out of the crank case
    I was trying to tell him in a nice way. Pretty sure it will not be good news.

  10. #10
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    I knew it wasn't going to be good, I will have to get the compression tester tomorrow and report back. Looks like my riding season might be over early. Gold, I was looking forward to riding with you all on the ohio river later on in september, looks like I might be turning to you for some help now though. I will keep you all posted.

Page 1 of 20 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2nd blown head gasket in less than 10 hours….need some insight
    By Boost-A-Holic in forum 4-Tec Performance
    Replies: 26
    Last Post: 07-04-2016, 01:10 AM
  2. My engine is getting full of water?????
    By GraniteMan in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 01-06-2009, 11:09 AM
  3. Help, Where can I get hose fittings?
    By mksmi in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-13-2008, 06:33 PM
  4. This happened in less than 2 hours...
    By grantuk in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-31-2008, 03:48 PM
  5. Ultra 250 less than an hour and its dead
    By Pesky Varmint in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 06-10-2007, 09:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •