Results 1 to 3 of 3
  1. #1

    Xp800 rave valve leaking

    Alright My Rave Valve is leaking i puled it apart today and the gasket seems to be fine the boot also seems to be fine however there a little bit of wear. So I guess im going to start there get a new boot and gasket. Unless someone else chimes in thanks
    <a href="" target="_blank"><img src="" border="0" alt="rave3"></a>

    <a href="" target="_blank"><img src="" border="0" alt="rave2"></a>

    <a href="" target="_blank"><img src="" border="0" alt="rave1"></a>

    <a href="" target="_blank"><img src="" border="0" alt="rave4"></a>

  2. #2
    Check your plugs and see if its running a little rich. Both mine tend to leak. Donno why they both will on the PWC but not on the triple sled.

    Ive pulled mine apart a few times and tried different methods, none which have lasted more then a couple hours use.

  3. #3

    Join Date
    Oct 2009
    Maasin, Southern Leyte, Philippines/CA
    best remedy is to change the rave valve and the rave housing,they tend to wear out,also the oring and gasket.check the bellows also for signs of melting.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. leaking rave valves and loss of power
    By juggaloXPracer in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-13-2010, 09:08 AM
  2. Replies: 6
    Last Post: 05-08-2010, 04:35 PM
  3. Rave valves leaking...
    By DooMeister in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-02-2009, 02:51 PM
  4. installing a rotary valve on 95 xp800
    By jrpetrie in forum 2-Stroke Performance
    Replies: 8
    Last Post: 03-06-2009, 07:55 AM
  5. tips on adjusting rave valves 96 xp800
    By flyby9er in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-07-2007, 06:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts