Results 1 to 9 of 9
  1. #1

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    What would make a VirageI top out at 40mph and 6000 rpm

    Hi all,
    I had my VirageI out this weekend after finally getting it running. (I had an EMM problem) The lake was relatively smooth and all I saw was 42 mph on GPS and 6000 rpm. It was a little underwhelming. Any ideas what would cause this. It ran great otherwise. Thanks.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    How's the impeller and stator vanes look?

    What's your impeller to wear ring clearance?

    How good are the pump bearings?

  3. #3

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    My thoughts were just like yours, so I took off all the pump parts and replaced them from another Virage that only had 23 hours, it was a carb ski that did 50 mph. The parts all looked really good. The ones that I took off the VirageI did not look that great so I was sure that was the problem. That was not the case, the ski only went 40mph at 6000rpm. So I am pretty sure there are no issues with the pump. Thanks.

  4. #4

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    I just discovered a loose spark plug, hopefully that is it. I will have a chance to find out this weekend.

  5. #5
    300+ pound rider will drop the top speed of any ski. I'm sure when they publish top speed of these skis it done with a light rider, just like jockeys in horse races.

  6. #6
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Quote Originally Posted by upallnight View Post
    300+ pound rider will drop the top speed of any ski. I'm sure when they publish top speed of these skis it done with a light rider, just like jockeys in horse races.
    Where did the 300+ pound rider come from? I didnt see that mentioned in the thread........

  7. #7
    Quote Originally Posted by jackofalltrades View Post
    Where did the 300+ pound rider come from? I didnt see that mentioned in the thread........
    No that wasn't mentioned in the thread, but as everyone know the published top speed by manufacturers are often exaggerated. I'm sure they don't test their ski with 300+ riders, but the weight of a rider do affect the top speed of a ski.

  8. #8

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Unfortunately the problem was not the loose spark plug. Rode for about an hour over the weekend, had the same max speed of 40mph (GPS) and 6000 rpm max. Just for the record I weigh 185lbs.
    I checked fuel pressure while idling on the trailer and was at 22psi.
    Any other ideas??

  9. #9
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Quote Originally Posted by dalepatter View Post
    Unfortunately the problem was not the loose spark plug. Rode for about an hour over the weekend, had the same max speed of 40mph (GPS) and 6000 rpm max. Just for the record I weigh 185lbs.
    I checked fuel pressure while idling on the trailer and was at 22psi.
    Any other ideas??
    Check the cylinder compression and let us know what you get. Be sure to hold the throttle wide open when you do this and ground the spark plug wires to prevent a spark from igniting fuel fumes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 RXDI cutting out between 3600 and 6000 rpm
    By mcar33 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-28-2013, 03:31 AM
  2. 99 gti topping out at 40mph, why?
    By derekshep in forum 2-Stroke Performance
    Replies: 10
    Last Post: 09-26-2013, 01:51 PM
  3. XLT 1200 only topping out at 40mph??
    By KIAmastertech in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-30-2013, 09:26 PM
  4. 01 GPR Topping out at 42mph 5500-6000 RPM...Help Please
    By SoundXplosion in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 05-06-2010, 10:46 PM
  5. Carbs Rebuilt, tops out at 55, and stripped head bolt issue..XLT1200
    By vjkevlar in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 08-06-2008, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •