Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Question UMI steering install problems?

    06 rxp

    I am in the process of installing my UMI kit, and im kinda lost. I just mounted the steering cable to the bracket and it seems wrong. pulls the base of center. i see there is HOW TO thread but its so old the pics are MIA.......getting this cable on is a huge pain and the directions are so vague its unreal....does the cable go on the bottom side of the bracket or top??? is the steering cable run the same way as it comes from factory or on top of the engine?? theres a few pieces in the kit that i have no clue how they go on, like the steering pivot looks like it can go a couple ways???????????????????



    PICS?????

    HELP????


    ANYTHING ????


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    The cable goes the same way but it can be tight. Take your time and reread the instructions they are good.

  3. #3
    I have that steering system on my new to me 07 RXP. I discovered this weekend that when you go WOT while the aftermarket bilge pumps are running, it repeatedly sends a tiny electrical shock through my nervous system. It was kind of scary on the water. Regardless, I'd be happy to post up pics if you can be a little more descriptive about what you'd like to see. Maybe you could take a pic and circle any areas that you want more detail?

  4. #4
    which way does the pivot go.towards the top or bottom???? the cable is so tight the base on top wont line up with the 4 holes

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    You can give it more cable by turning the nut. Don't forget that the bracket goes into the groove.

  6. #6
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    I mean the groove on the cable goes into the umi holder

  7. #7
    yea i got it in the groove and bolt on....ill post pics after work

  8. #8
    ok here are some pics of the partial install... i got the steering cable hooked up and the steering goes lock to lock real nice and smooth!!! happy about that!! i still have some pieces that i have no friggen clue where they go hopefully other UMI guys can chime in

    pic 1

    i know where the steering pivot and hood striker anchor go but the UMI plate and little straight thing i have no clue



    pic2

    looking into the hull from the front, steering cable hooked up but not attached to the pivot



    pic3

    front again with the cable completely hooked up and in the first pivot hole because thats the only hole that didnt bind



    pic4

    front again just a different pic



    pic5

    rear intake hole looking in..


  9. #9
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    You dont need the pieces I circled for an RXP they are for a primer and the other is a button holder. .

    The steering arm bolt to the bottm of the stem there. It will go to the right.

    Looks like you dont have a DESS holder ? if not open up the primer holder to accept the DESS post.

    You can take out the bracket for the airbox there. Assuming you are running aftermarket air of some sort.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	umi.jpg 
Views:	98 
Size:	63.1 KB 
ID:	249904  

  10. #10
    i had the the cable bolted to that hole on the steering arm and it was binding....move it oppisite side and it was ok???

    what about the thin piece on the bottom?? no use? and the random holes on the steering plate that are open?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "HOW TO" Umi Steering Install
    By CarFanatic in forum Sea Doo How To & FAQs
    Replies: 34
    Last Post: 01-15-2012, 04:39 PM
  2. UMI Steering Install.... NEED HELP & PICS!
    By GTLaser in forum 4-Tec Performance
    Replies: 13
    Last Post: 12-09-2009, 09:22 PM
  3. Replies: 22
    Last Post: 09-09-2009, 06:39 PM
  4. UMI Steering install problems... any how to thread links?
    By o uncola o in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 01-05-2009, 07:26 PM
  5. UMI steering install (RXP) question
    By mstennes in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-02-2008, 12:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •