Results 1 to 5 of 5
  1. #1

    2004 Virage i dead

    My nephew was riding my 2004 virage i and it just quit. There is no display, wont even crank. I have not had a chance to look at it, other than throw a battery charger on it and tighten the battery connections (which were a little loose). I am hoping it is something stupid. Where should I start?


  2. #2
    Sounds like battery took a dump, check with load tester after charging

  3. #3
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Quote Originally Posted by egstasea View Post
    My nephew was riding my 2004 virage i and it just quit. There is no display, wont even crank. I have not had a chance to look at it, other than throw a battery charger on it and tighten the battery connections (which were a little loose). I am hoping it is something stupid. Where should I start?
    Check the 2 15 amp circuit breakers and see if they are tripped. I would seem to think even if the battery died the stator would have still supplied enough power to run the ski?

  4. #4

    fixed

    It was a fuse. I think the loose battery terminal took it out.

  5. #5
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Quote Originally Posted by egstasea View Post
    It was a fuse. I think the loose battery terminal took it out.
    Glad you got it fixed. The loose battery terminal could have caused a spike for sure.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with 2004 Virage
    By lm534 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 05-31-2010, 03:48 PM
  2. Help with 2004 Virage
    By lm534 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 05-31-2010, 03:43 PM
  3. 2004 Polaris Virage display dead won't start
    By jeffreyb in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-27-2009, 10:47 PM
  4. 2004 virage up-grades
    By fatboy in forum Polaris PWC Performance
    Replies: 1
    Last Post: 07-09-2008, 11:25 AM
  5. 2004 Virage 700 NO POWER!!!
    By roscodop in forum Polaris Open Discussion
    Replies: 16
    Last Post: 06-18-2008, 09:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •