Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2011
    Location
    Reno beach, OH
    Posts
    5

    2002 polaris virage i fuel issues

    i have a 2002 virage i just intstalled a kawasaki inline fuel pressure regulator has good fuel pressure. the fuel pressure regulator on the fuel pump fell off in the tank thats why i put the kawaski regulator on. the ski ran great for about a quarter mile then died. put l.e.d. code reader on and its reading a 51 and 52 open load on both injectors. not sure what to do next spark plugs are fine have good color and compression on both cylinders are good as well


  2. #2

    Join Date
    Aug 2011
    Location
    Reno beach, OH
    Posts
    5
    does anyone have any suggestions

  3. #3
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Check the voltage on the red/white wire going to the injectors. Should have about 20V while cranking and should jump up to about 45V if it starts. Do not unplug the injectors when you test for voltage.

  4. #4

    Join Date
    Aug 2011
    Location
    Reno beach, OH
    Posts
    5
    k thanks will check that and let u know

  5. #5

    Join Date
    Aug 2011
    Location
    Reno beach, OH
    Posts
    5
    checked the voltage to injectors has 20v while cranking and 45v while running would the tps affect how its running?

  6. #6
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    The TPS can make it do wierd things and the bad part is you cant really bench check them reliably. I would seem to think however if it had smooth acceleration and there was no codes in the EMM for the TPS then its something else. Did you get any warnings on the screen when the ski died? Also check to make sure the cooling line going to the EMM is not blocked, to include checking the passage through the EMM with a ziptie or something. If that is open, you can check the stator and engine grounds. Since you got the proper voltage on the injectors I dont think the EMM is the issue right now but if the cooling line is blocked it can overheat.

  7. #7

    Join Date
    Aug 2011
    Location
    Reno beach, OH
    Posts
    5
    k will check the lines going to the emm and see if its clogged thanks alot

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to Remove and repair Ficht fuel pump on 2002 polaris virage txi
    By john8873 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-26-2016, 11:36 AM
  2. 2002 polaris virage 800i DI...lanyard issue.
    By johnnyboy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-22-2014, 03:56 PM
  3. 2002 Polaris Virage I 800 Direct Injection Fuel Pump Question
    By perthaustralia in forum Polaris Open Discussion
    Replies: 35
    Last Post: 03-23-2014, 09:37 AM
  4. 2002 Polaris Virage TXi (unknown issues?)
    By 02VirageTXi in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-18-2011, 06:26 PM
  5. 2002 Polaris Virage I no fuel pressure
    By mhs in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-27-2008, 09:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •