Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    need help for tomorrow!

    So I am trying to put the stock sound suppression in and am having no luck. I pulled everything out to do the pump tunnel reinforcement and now it wont fit back together. I'm pretty sure the big square like styrofoam is suppose to go under the stock black sound suppression. But with that in place, the black box will just barely touch the coupler on the exhaust exit before hitting the hull. I pulled off the coupler from the metal piece to make sure it is not on to far, but still, I am barely getting any contact between the supression and the coupler. What am I doing wrong here?

    Two other questions
    1. Where does the small piece of styrofoam go?
    2. On a parts fiche, the front ventilation hoses cross over. When I got the ski, both hoses were just wrapped around on the same side. Which way is right? The trim cable was pulled out and now the plastic tube is blocking the cable from being able to snap into place.

    I want to go out this weekend and need some serious help and advise here guys.


  2. #2
    Would I be better off doing the studs in the metal elbow thing and connect all the pieces, then tighten down the metal elbow last?

  3. #3
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,310
    +1
    45
    Quote Originally Posted by venomous View Post
    So I am trying to put the stock sound suppression in and am having no luck. I pulled everything out to do the pump tunnel reinforcement and now it wont fit back together. I'm pretty sure the big square like styrofoam is suppose to go under the stock black sound suppression. But with that in place, the black box will just barely touch the coupler on the exhaust exit before hitting the hull. I pulled off the coupler from the metal piece to make sure it is not on to far, but still, I am barely getting any contact between the supression and the coupler. What am I doing wrong here?

    Two other questions
    1. Where does the small piece of styrofoam go?
    2. On a parts fiche, the front ventilation hoses cross over. When I got the ski, both hoses were just wrapped around on the same side. Which way is right? The trim cable was pulled out and now the plastic tube is blocking the cable from being able to snap into place.

    I want to go out this weekend and need some serious help and advise here guys.
    If your going with the stock system try not to use any bad words LOL. If you go with the free flow exhaust it is a lot easier and you can get rid of those 2 pieces of styrofoam. But if you use the stock suppression system put the aluminum elbow in first then the connection hose then the big piece of foam in then the suppression box then connect all the hoses its a tight fit but they will go on. if you got a long extension you can use a socket to tighten the clamps. the small piece of foam goes against the right side of the ski and is conformed to the hull. hope this helps.

  4. #4
    hmm. That is exactly what I tried to do. But the supression box is hitting the inside of the hull and it is barely touching the coupler that is connected to the elbow.

  5. #5
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,310
    +1
    45
    Quote Originally Posted by venomous View Post
    hmm. That is exactly what I tried to do. But the supression box is hitting the inside of the hull and it is barely touching the coupler that is connected to the elbow.
    One side of the rubber elbo is longer than the other make sure you got it in right.

  6. #6
    just checked and the longer end is facing the suppression box

  7. #7
    the ventilation question should be a quick answer if someone could chime in.

  8. #8
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,639
    +1
    404
    Quote Originally Posted by venomous View Post
    So I am trying to put the stock sound suppression in and am having no luck. I pulled everything out to do the pump tunnel reinforcement and now it wont fit back together. I'm pretty sure the big square like styrofoam is suppose to go under the stock black sound suppression. But with that in place, the black box will just barely touch the coupler on the exhaust exit before hitting the hull. I pulled off the coupler from the metal piece to make sure it is not on to far, but still, I am barely getting any contact between the supression and the coupler. What am I doing wrong here?

    Two other questions
    1. Where does the small piece of styrofoam go?
    2. On a parts fiche, the front ventilation hoses cross over. When I got the ski, both hoses were just wrapped around on the same side. Which way is right? The trim cable was pulled out and now the plastic tube is blocking the cable from being able to snap into place.

    I want to go out this weekend and need some serious help and advise here guys.
    you dont need any of that styrofoam, just chunk it IMO

    on the hoses, I just run them from the elbows straight down besides the tank

  9. #9
    You don't have to worry about water weight with the suppression box not being supported?

    WFO, are you just running the hose and not the plastic ventilation tubes?

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,639
    +1
    404
    Quote Originally Posted by venomous View Post
    You don't have to worry about water weight with the suppression box not being supported?

    WFO, are you just running the hose and not the plastic ventilation tubes?
    no... I never put the foam block back on any of the GPRs I have built

    yes, just the hose and not the lower tubes

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help for tomorrow
    By whiteyz in forum Yamaha PWC Performance (2-stroke)
    Replies: 32
    Last Post: 06-02-2008, 03:47 PM
  2. need help for something stupid
    By gba in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-01-2008, 03:39 PM
  3. need help for tuning pro 785
    By pro145hp in forum Polaris PWC Performance
    Replies: 7
    Last Post: 04-07-2007, 05:13 PM
  4. need help for 1st jet-ski
    By jt98boosted in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 03-30-2007, 02:15 PM
  5. !!Need help for SPEED!!
    By Chezzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 12-24-2006, 03:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •