Results 1 to 8 of 8
  1. #1
    Xrunner's Avatar
    Join Date
    Dec 2010
    Location
    Columbia river
    Posts
    285
    +1
    1

    Should the nozzle be loose?

    I was wondering if it is normal to have a little play in the nozzle? It looks like the linkage for the trim adjust is what holds it in place and obviously is what moves the nozzle up and down. It has about an inch of play in it. Maybe a bit less than an inch. Nothing looks loose as far as i can tell. It has been like this since i bought it in Feburary. 2009 with zero hours on it. Now it has 50.

    Maybe i will post up a vid of me moving it around with my hand if that would help.


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by Xrunner View Post
    I was wondering if it is normal to have a little play in the nozzle? It looks like the linkage for the trim adjust is what holds it in place and obviously is what moves the nozzle up and down. It has about an inch of play in it. Maybe a bit less than an inch. Nothing looks loose as far as i can tell. It has been like this since i bought it in Feburary. 2009 with zero hours on it. Now it has 50.

    Maybe i will post up a vid of me moving it around with my hand if that would help.
    The cable ends on the handle bar have to be adjusted out to get rid of the play.

  3. #3
    Xrunner's Avatar
    Join Date
    Dec 2010
    Location
    Columbia river
    Posts
    285
    +1
    1
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    The cable ends on the handle bar have to be adjusted out to get rid of the play.
    I see, i didnt really look at that end much as i was mainly wondering about the nozzle end. Thanks for the info.

    So i have this correct: I want to take ALL the play out of it?

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by Xrunner View Post
    I see, i didnt really look at that end much as i was mainly wondering about the nozzle end. Thanks for the info.

    So i have this correct: I want to take ALL the play out of it?




    Read the manual....there is always a small amount of play in cables

  5. #5
    Xrunner's Avatar
    Join Date
    Dec 2010
    Location
    Columbia river
    Posts
    285
    +1
    1
    Quote Originally Posted by RickWhite View Post
    Read the manual....there is always a small amount of play in cables
    Dont have one. Hence, why i posted. How much play are we talking ?

  6. #6
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    My fzr has had play in the nozzle since day one. I wouldn't say an inch, maybe a quarter of an inch.

  7. #7
    shiftarno's Avatar
    Join Date
    Jul 2010
    Location
    SOUTH JERSEY
    Posts
    288
    my new one has a lil play in it

  8. #8
    Xrunner's Avatar
    Join Date
    Dec 2010
    Location
    Columbia river
    Posts
    285
    +1
    1
    Ok, so i went out and looked at the trim cables where they meet the hand grip. Heh, i never really looked at that before. Its kinda outta sight, outta mind in that spot i suppose. I kept looking at all that play at the nozzle and looking behind the curtains where the linkage leads. Cant quite see it, but it looks like there is some kind of adjustment for it in there. Couldnt really tell.

    Anyways, i was able to adjust the play out of it at the handgrip side of the cables. 2 of them there. I just backed off the locking nuts and backed both of the adjusters just a turn and a half. Then checked the play at the nozzle. Nice and tight... actually about 1/4 inch of play now. Tightened the locking nuts back up and im good.

    Thanks for the replies that were actually helpful

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What should the compression be?
    By Cem22 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 11-14-2011, 02:02 PM
  2. What should the RPM be at idle out of water for 300x
    By cmexeqtu2 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-13-2011, 09:49 AM
  3. tps setting question...what should the degrees be at?
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-25-2009, 05:54 PM
  4. How rough should the idle be?
    By Rio Vista in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 03-13-2007, 01:33 PM
  5. What should the speed be of a "stock" 2005 RXT?
    By BrAinZ in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-05-2006, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •