Results 1 to 2 of 2
  1. #1

    RXP Display issue

    When I put the key in all my displays come on, then I recieve a single longish beep and the left and right sections of the LED go blank. I see "Sea Doo Hrs" in the lower center and then get the normal 4 beeps. I have cleaned and reconnected the battery, the key and key post. Any thoughts? I will try to access display connector and see if it is clen well connected.


    2006 RXP IC SC

  2. #2
    Single long beep is normally an active fault, need to see what the fault is. Half the display should not turn off...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1100 STX Display Issue
    By barthel in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 06-06-2011, 06:15 PM
  2. WTB Need a 06 display screen for a rxp
    By beachboy66 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 11-03-2010, 09:13 PM
  3. gp760 display issue
    By skyline2962 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-21-2010, 07:31 PM
  4. 2001 - Pro 1200 - MFD Display Issue
    By elwayisgod in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-14-2009, 08:26 PM
  5. Display/Electrical Issue , Part 2
    By washingtonrider in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-26-2006, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts