Results 1 to 10 of 10

Thread: VXR Problems

  1. #1

    Join Date
    Aug 2011
    Location
    Fort Myers, Florida
    Posts
    4

    VXR Problems

    Hi everyone. I'm a first time user here and pretty new to jet skis.

    I'm having some problems with my VXR. Last week I noticed that it was lacking a lot of power in both acceleration and top end speed. There just isn't that power off the line like it used to have, and I lost about 10 mph off the top speed. To make matters worse, my dad was cruising around on it today and heard a pop. This led to the steering become very hard. I would have to use a lot of strength to even budge the handle bars. This all led to a day at the beach being cut short

    I took it to the dealership today since it's still covered under warranty. The ski only has 33 hours on it and isn't abused. Any thought on what could be the problem with it?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,445
    +1
    650
    First off welcome to the Forum.....

    Second off , If there was a loss of power and not running right, why would you keep using it?
    could be numerous things, have you or some one riding it sucked some thing in to the intake grate? any body hit something........to many unknowns.....

  3. #3

    Join Date
    Aug 2011
    Location
    Fort Myers, Florida
    Posts
    4
    There is a possibility that sea weed may have been sucked up. The area we ride at in the bay doesn't usually have any but it is a possibility. The thing is before we noticed the lack of power or top speed, it was running strong and with the usual power. We always check to see if anything is in the intake grate or around the impeller. Then we took it out again the following week and right from the start it was just lacking. Shouldn't something being sucked up have an immediate effect on the jet ski?

    Also nothing had been hit or sucked up when the steering started becoming difficult. My dad just said he heard a pop and that's when the steering problem happened. Where he was riding there was nothing in the water and it wasn't shallow. We checked the intake grate when this happened and there was nothing. The steering cable was connected, but I'm not sure what could have caused this.

  4. #4
    Maybe a fouled spark plug, could be running on 3 cylinders??

  5. #5
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Overfilled with too much oil!

  6. #6

    Join Date
    Aug 2011
    Location
    Fort Myers, Florida
    Posts
    4
    Quote Originally Posted by RickWhite View Post
    Overfilled with too much oil!
    The oil level was fine

  7. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,445
    +1
    650
    Maybe where you launched at something went thru the pump ........take a flash light and take a close look from the back and thru the intake grate and see if there is any damage to the impeller or housing......

    Does it cavitate on hole shot?

  8. #8
    laspalmas's Avatar
    Join Date
    Jul 2011
    Location
    KOH SAMUI - THAILAND
    Posts
    38
    i have exactly the same problems. Take a look at my impeller. This is caused because too much small rocks and sand and ride too much near the beach. I don't know yet if it's 100% the reason why my ski lost power same as yours but there is a lot of chance that's because of this. And as said by RickWhite i had too much oil too so many things in same time not good. Anyway your dealer will see it very fast to find from where the problem is coming from.




  9. #9

    Join Date
    Aug 2011
    Location
    Fort Myers, Florida
    Posts
    4
    Laspalmas, thanks for the info. It's a real possibility that this could be the problem with the loss of performance. This is what I was thinking it could be. Hopefully the dealer gets back to me soon.

  10. #10
    laspalmas's Avatar
    Join Date
    Jul 2011
    Location
    KOH SAMUI - THAILAND
    Posts
    38
    please let us know what your dealer say i'm interested

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 VXR Problem
    By dom1220 in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 08-17-2013, 08:48 PM
  2. 2013 VXR Problem !
    By dom1220 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-30-2013, 06:45 PM
  3. Yamaha vxr 10hours - problem started + custom build
    By laspalmas in forum Yamaha PWC Performance (4-stroke)
    Replies: 45
    Last Post: 11-11-2011, 08:01 AM
  4. 94 pro vxr 700 electrical problems
    By tillerytime in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 05-04-2010, 06:11 PM
  5. Problems with 94 VXR Pro
    By SeaGoat in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 03-30-2009, 09:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •