Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    2008 RXP 215 -SUDDEN- Loss of powe. Supercharger? Covered under ext. warranty?

    Summary of questions asked here;
    Is this problem my SC?
    Should it be covered under my extended warranty?

    ****************************
    I have a 2008 RXP 215 that I have owned since purchased brand new at the dealership.

    There is currently 169 hours on the ski.

    I was riding today and the pull / power just dropped to about 6440 RPM and about 56 MPH reading on the speedo.

    It was -VERY- sudden. One second, everything was fine. I was feeling the great feeling of a powerful pull that has taken me to about 70MPH ever since brand new.

    Then, literally, from one second to the next, DROP.

    From there all the way back to the marina, the ski ran perfectly, but only to the aforementioned 56 MPH and 6440 RPM.

    I strongly suspect that it is the supercharger.

    Any feedback confirming or otherwise is sought.

    I have an extended warranty. It runs out in October of 2012. It is the extended warranty that is offered by the manufacturer of the ski, not an aftermarket warranty provider.

    SC rebuilt at 85-87 hours using titanium washers;
    When the ski had about 85-87 hours on it, I found out that my warranty required that the supercharger be rebuilt every 100 hours. So, at 82-85 hours the Ski was running fine... perfectly.... ZERO problems. BUT, I had to rebuild the supercharger anyway in order to keep the warranty.

    So, one of the local dealerships told me that if I claimed the ski was losing power, that SeaDoo would cover the SC under warranty.

    SO, the point of this tid-bit of history is that the SC was rebuilt at 85-87 hours even though it did not need it.

    All recommended service and maintenance has been performed since new.

    So, does this sound like my SC please?

    Will it be covered under warranty?
    Anything I should do or say, any way in particular I should 'act' to help make this a covered repair?


  2. #2
    mac_man_luke's Avatar
    Join Date
    Sep 2010
    Location
    South Australia
    Posts
    1,262
    +1
    22
    Quote Originally Posted by dolphinride View Post
    SO, the point of this tid-bit of history is that the SC was rebuilt at 85-87 hours even though it did not need it.
    When rebuilding the charger there should be no "symptoms" that would tell you, you need to rebuild.

    You rebuild a charger as preventative maintenance no more than every 100 hours - prevents clutch failure and bearing failure.

    Does sound like your charger has gone, warranty should cover it - make sure they clear the motor of any debris, not just fix the charger or you will have more problems very soon.

  3. #3
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    It sounds like the hose on the outlet of the supercharger came off. Did you check it?

  4. #4
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    +1 the first time it happen to me thought i had screwed something up good check your hose from SC to TB
    Quote Originally Posted by sn-95 View Post
    It sounds like the hose on the outlet of the supercharger came off. Did you check it?
    really don't think there is anything wrong with SC just the hose blew off easy fix mine has come off alot bought new hose but have not put on yet just clean the oil off hose and reconnect it

  5. #5

    Seeking techie local to Clearwater / Largo / St. Petersburg to help disgnose '08 RXP

    I am the original poster of this issue.

    I want to check several things on this ski after reading the responses posted here, and doing some research in a few other places as well.

    I intend to check the SC hose, the SC belt, and someone suggested I take a look at the ware ring.

    This 'might' be something that I can see and fix myself, but maybe not.

    I am not mechanically inclined with these things.

    I would like to find someone in the Clearwater / Largo / St.Petersburg area that would be willing to take a look at the ski with me.

    Let me know if you might be able to do it, or if you know someone who might.

  6. #6
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by dolphinride View Post
    I am the original poster of this issue.

    I want to check several things on this ski after reading the responses posted here, and doing some research in a few other places as well.

    I intend to check the SC hose, the SC belt, and someone suggested I take a look at the ware ring.

    This 'might' be something that I can see and fix myself, but maybe not.

    I am not mechanically inclined with these things.

    I would like to find someone in the Clearwater / Largo / St.Petersburg area that would be willing to take a look at the ski with me.

    Let me know if you might be able to do it, or if you know someone who might.
    Just pop off the rear seat. Remove the big plastic air tube and look below it. There will be a large diameter hose coming off the top of the supercharger. Just check to see if it is still connected. "Easy as pie bro."

    BTW, there is no supercharger belt. and I doubt you have a wear ring problem.

  7. #7

    Forgot to mention.... I have a 'blow-off valve' installed.. Is taht the hose?

    I have a blow-off valve installed.

    It is a big blue hose.

    I presume this is the hose to inspect?

  8. #8
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by dolphinride View Post
    I have a blow-off valve installed.

    It is a big blue hose.

    I presume this is the hose to inspect?

    Yes, Inspect the valve too. If it is stuck open you could have similar symptoms.

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    FYI! That BOV will cause your SC clutch to wear faster. I would remove it as it is NOT needed....

  10. #10
    Wanted to follow-up. Sorry so late. It was the SC hose that had come off. A new hose clamp fixed it. On another note, I really believe that the blow-off valve (BOV) really contributed to the longevity of my supercharger.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 12-03-2017, 10:40 AM
  2. Replies: 2
    Last Post: 05-09-2016, 03:16 PM
  3. Sudden loss of power diagnosis?
    By ascauto3 in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 05-09-2009, 01:09 PM
  4. Sudden loss of power diagnosis?
    By ascauto3 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 05-09-2009, 10:50 AM
  5. 2006rxp Sudden Loss of power and vibration
    By filterthis2008 in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-08-2008, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •