Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Question Polaris slt 750 almost dies after 180 deg turn

    old slt starts and runs pretty darn good
    But when I do a 180 it almost dies,never does, but almost
    revs about 2000 rpm for 2,3 sec and comes back to life.
    old dash display works but fuel indicator doesnt
    thinking maybe its falling into limited mode because of fuel guage?
    or are there other reasons?

    machine starts right up no problems even cold ,hardly ever needs choke.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check the fuel pickups in the tank. make sure you arent sucking air when you spin .

  3. #3
    I will check them tomorrow!
    do the 750 sl or slt,s lower rpm or retard timing when low fuel is indicated?

  4. #4
    Carson's Avatar
    Join Date
    Jul 2011
    Location
    TX
    Posts
    273
    Quote Originally Posted by craneman View Post
    old slt starts and runs pretty darn good
    But when I do a 180 it almost dies,never does, but almost
    revs about 2000 rpm for 2,3 sec and comes back to life.
    old dash display works but fuel indicator doesnt
    thinking maybe its falling into limited mode because of fuel guage?
    or are there other reasons?

    machine starts right up no problems even cold ,hardly ever needs choke.
    Upgraded fuel pump or original?

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by craneman View Post
    I will check them tomorrow!
    do the 750 sl or slt,s lower rpm or retard timing when low fuel is indicated?
    NO, they do not have a limiter. I was riding my friends SLT 750 and doing spins while it was low on gas and it died out on me a few times. Thats why I suggested checking the fuel pickups.

  6. #6
    original pump and yes i will check fuel pickup but the machine was full full of fuel

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Carbs ever rebuilt?

  8. #8
    no the carbs look original,, I'll send pic's
    Oem paint on all hoses runs great ,,
    note: was running great and we put a new fuse for the digital display 1/4 amp bigger than it says in manual.
    then it started to do weird things like what i explained ,,everything works on display except for fuel guage
    hence my Q
    in the manual that ive been reading and reading ,,troubleshooting does say that low fuel could cause rev limitation or timming retarding ??
    as soon as ski is in a stable line or not spinning it runs about 45 mph regularly!
    compression is 129 123 130 ,, manual says acceptable!
    I will disable display and check all fuel line and everything related to fuel and get back to you !!
    Thx. to all that Replied
    note : I will also ohm out fuel guage in tank!
    Back in the water for another test !! Love it !!
    note ::::: it hits 5900 rpm easy is this normal or should it be higher?

  9. #9
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    That seems on the low side to me, my slt750 does 6200rpm. I don't know for sure how fast my ski goes though as I know for a fact my MFD reads about 5mph. According to my MFD the ski does 55-56mph. Comparing that to a buddies ski my guess is it does high 40's and maybe 50mph in calm water.

    Have you gone through the fuel system at all? Taken a look at piston wash?

    I have a suspicion that you are on the lean side. It might not be a bad idea to look into rebuilding the carbs and upgrading to a triple output fuel pump as the factory ones are just barely enough to support these Fuji engines when they are new let alone when they have some wear and tear from normal usage...

  10. #10
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    use the correct 1/4 amp fuse. should do 48-50 mph on the MFD at 6250 rpms. check your piston wash immediately and see where your at. no limp mode..

    you need a complete overhaul of the fuel system. all lines,filters,carbs,pulse line,ditching auto cock,follow beerdarts diagram. costs about 250.00 for everything.

    they need it.. they are 16 years old. check the tank lines too. change them and keep track which ones are longer, thats your reserve and main. dont confuse them.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 Polaris SLT 750 Engine cutting out after repairs
    By kxs in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-03-2009, 11:16 PM
  2. Question for a Polaris slt 750
    By Rodney in forum Polaris How To & FAQs
    Replies: 31
    Last Post: 08-10-2007, 12:25 AM
  3. Polaris SLT 750 - Where do you mount the fuel pump?
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-28-2007, 07:54 PM
  4. Polaris SLT 750 X Problems!
    By publiccraze in forum Polaris PWC Performance
    Replies: 7
    Last Post: 06-25-2007, 11:59 PM
  5. 95 polaris slt 750 no spark
    By The Joker in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 11-20-2006, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •