Results 1 to 3 of 3
  1. #1

    Polarsi SL750 1995

    I have to jump start my sl750 and NOW when I hit the start button its won't crank but the MFD goes blank and back on?? Battery is fully charged and all connections are good not sure whats up any ideas...Thanks


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your ground connection!

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Battery installed correctly?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 SL750 Heart Surgery
    By SantaCruz163 in forum Polaris Projects
    Replies: 25
    Last Post: 08-11-2008, 05:05 PM
  2. 1995 Sl750
    By gorilla03 in forum Polaris Projects
    Replies: 232
    Last Post: 02-18-2008, 09:14 PM
  3. Replies: 0
    Last Post: 09-27-2007, 03:54 PM
  4. 1995 Polaris sl750 Bilge pump question .
    By smittyj77 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-29-2007, 12:47 AM
  5. Newbie who purchased a 1995 Polaris SL750 and have some questions
    By Great_Outdoors_5911 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-18-2007, 10:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •