Results 1 to 2 of 2

Thread: trouble

  1. #1

    trouble

    own 1995 polaris pwc 650. don t seem to be getting fuel, yes gas turned on, cleaned separator, new gas filters, blew out lines, cleaned tank, engine runs if spray mist in engine, do not se mist of gas if touch throttle, is there fuel pump or other suggestions


  2. #2
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Stuck needles, filters inside carbs are clogged, cracked diaphragms, ... Take the carbs out and apart for a thorough inspection.
    Here's a good thread for "Getting to know your ski":
    http://www.greenhulk.net/forums/show...-750-780-785-s

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tip: Trouble codes for 4 Tec's
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 73
    Last Post: 06-02-2017, 07:34 PM
  2. 12 Offshore Oil Rigs in trouble...USCG
    By Denali44 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 09-01-2005, 11:23 PM
  3. trouble code ?
    By Krazy-K in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-01-2005, 07:18 PM
  4. Replies: 22
    Last Post: 07-13-2005, 09:33 PM
  5. Impeller Shaft Trouble
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-06-2005, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •