Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166

    FZR high RPM at idle!

    Hello everyone, I am new here and this is my first post/quistion, I have a FZR 09' just upgraded it with the following stuff,

    1-Riva E1 SC impeller
    2-Riva FPR
    3-autometer boost gauge
    4-Riva stock intercooler upgrade kit
    5-Riva BOV
    6-R&D multi-pressure port boost adaptor kit
    7-Riva FF Exhaust
    8-Riva engine breather
    9-Riva power filter kit
    10-R&D power core intake (manifold upgrade kit) with a intercooler CFM kit
    11-Riva boost clamp
    12-Riva Engine Cooling Upgrade Kit
    Now, first thing i noticed that the boost gauge reads at -20 i mean it starts counting from the Vac numbers toward the boost pressure numbers. Second the the RPM is quite high almost 1400-1500 revs at idle, are thos things normal??
    note, the vac line for the RRFPR is taken from the manifold which was drilled and tapped and it was set to 55 psi as Riva said. The BOV and the boost gauge are using the R&D adaptor. I am loacated in Dubai which is at sea level and temps are very hot. Thanks in advance for any reply


  2. #2
    Taking money away from the Z06 Fund
    Join Date
    Sep 2007
    Location
    Gainesville, VA
    Posts
    560
    +1
    1
    Quote Originally Posted by waseemyah View Post
    Hello everyone, I am new here and this is my first post/quistion, I have a FZR 09' just upgraded it with the following stuff,

    1-Riva E1 SC impeller
    2-Riva FPR
    3-autometer boost gauge
    4-Riva stock intercooler upgrade kit
    5-Riva BOV
    6-R&D multi-pressure port boost adaptor kit
    7-Riva FF Exhaust
    8-Riva engine breather
    9-Riva power filter kit
    10-R&D power core intake (manifold upgrade kit) with a intercooler CFM kit
    11-Riva boost clamp
    12-Riva Engine Cooling Upgrade Kit
    Now, first thing i noticed that the boost gauge reads at -20 i mean it starts counting from the Vac numbers toward the boost pressure numbers. Second the the RPM is quite high almost 1400-1500 revs at idle, are thos things normal??
    note, the vac line for the RRFPR is taken from the manifold which was drilled and tapped and it was set to 55 psi as Riva said. The BOV and the boost gauge are using the R&D adaptor. I am loacated in Dubai which is at sea level and temps are very hot. Thanks in advance for any reply
    I believe your idle vacuum should show around -17 or so. Idle RPM should be around 1280-1300rpms, do you have an aftermarket tach to show the exact rpms?

    Do you have an Air Fuel gauge and if so, what does it show at idle? How about at WOT?

  3. #3
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166
    thx poof for your reply, the boost gauge shows about -20 or less its analog so I am estimating it, and nope i have got no aftermarket tach, and about the air/fuel gauge i dont have it either. so far i have not taken it to test it at the water, i was a bit scared that i did something wrong

  4. #4
    Taking money away from the Z06 Fund
    Join Date
    Sep 2007
    Location
    Gainesville, VA
    Posts
    560
    +1
    1
    Welcome to the site!! If I were you, I'd put an Air/Fuel gauge on your ski, especially with the E1 on there, although you don't have a ECU reflash. I'd still see what your AF#s are at idle and WOT. Did the ski idle this high before you added all of the parts? I'd also get a PET tach so you can get the exact RPMs you see at idle and for WOT for prop tuning.

    I'd try to put those gauges on before water testing if possible. That way you can get a better idea of whats going on with your ski and how to adjust with the FPR.

  5. #5

    Join Date
    Jul 2011
    Location
    NYC/Long Island
    Posts
    35
    An aftermarket intercooler should be essential for where you are located.

  6. #6
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166
    everything was ok and it was making about 1100-1200 revs per minute before I added those things, so i installed all these parts my self and fired it for the first time and gou those numbers I mentioned above, after all i am estemating, i got nothing else to count on other than the stock tachometer and that boost gauge

  7. #7
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166
    thx Champion for your reply, i am using the Riva stock IC upgrade kit and i think that si enough for now

  8. #8
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    When was the last time you lubed your throttle body?

  9. #9
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166
    thx 5001craig for your reply, in fact i have never done it my self but like 4 or 5 months ago it was at the dealers workshop for some regular maintenance, I have no idea if they lubed it or not, but if you know how to lube it, just tell me and i will do it my self, hopefully no need to take the manifold out again

  10. #10
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Quote Originally Posted by waseemyah View Post
    thx 5001craig for your reply, in fact i have never done it my self but like 4 or 5 months ago it was at the dealers workshop for some regular maintenance, I have no idea if they lubed it or not, but if you know how to lube it, just tell me and i will do it my self, hopefully no need to take the manifold out again
    Service manual says to spray into the intake breather hose with a rust inhibitor (fogging oil) while the engine is running for five seconds. The manual shows the breather hose removed from the oil scavenger and spraying from that end.

    I had a similar high idle situation and started a thread last year: http://www.greenhulk.net/forums/show...throttle-cable. It's all here in the Hulk--just have to do the homework.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. High RPM at Idle and losing RPM at wot
    By Redsea_rider in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-02-2014, 08:20 AM
  2. normal rpm at idle and wot???
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-25-2010, 07:46 PM
  3. High revs at idle
    By MARK_LEGG in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-17-2009, 10:02 AM
  4. High Revs at idle
    By tonkatiger in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 07-02-2008, 10:01 PM
  5. High RPMs At Idle
    By JFizzleJR in forum 4-Tec Performance
    Replies: 28
    Last Post: 07-09-2007, 08:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •