Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: spark plugs

  1. #1

    Join Date
    Oct 2010
    Location
    central Illinois
    Posts
    19

    spark plugs

    Hi all.

    I have a 2009 STX-15f. I bought it new from the dealer last year. It has run great. Last week I raffed out for a couple of hours and then tried to start it up. It would turn over but not ignite. No codes except FPO. Long story short got towed in and took it to the dealer on tuesday. Wednesday the tech came out and started it right up. Again no codes except FPO.

    He suggested a new set of new plugs. NKG CR9EK four of them were put in. Took it out on the river today and I am utterly amazed of the difference in performance. The plugs were the orginals which I guess was the reason for all this and were shot. I will be putting in a new set every year in the spring for now on.

    I have owned boats all my life and with my 30 footer crusier it is every other year for plugs which I could go every three years almost.

    Is this normal for plug wear on these jet skis one year tops? Four new one a year is no big deal and I like to have my little baby running like a top.

    Thanks


  2. #2
    Banned User
    Join Date
    Apr 2011
    Location
    Miami, FL
    Posts
    244
    depends how much use you give to the ski, i changed mine at the 45 hour mark, and when i saw how cheap those CR9EK are i'll problably change them every 10 hour

  3. #3

    Join Date
    Oct 2010
    Location
    central Illinois
    Posts
    19
    I had about 30 hours on the orginals............what is the alternative? Give me a brand?

  4. #4
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by mrbigsea View Post
    I had about 30 hours on the orginals............what is the alternative? Give me a brand?
    That's normal cr9ek are good and cheap for a na boat like urs. Some run then in there ultra as well.

  5. #5

    Join Date
    Oct 2010
    Location
    central Illinois
    Posts
    19
    Thanks for the info........picked up 4 spares at the auto parts store for $4.83 a piece.........such a bargain!

  6. #6
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Plugs more than likely werent the problem.....some 15fs have a hard time restarting after sitting for a while after running them for a while.....seems to be between 15 to 30 mins of sitting .....if it happens again pull the seat off, let it cool off/fresh air in the hull for a few mins....it should start right up after cooling down....had a 2006 15f that would do it quite often.......

  7. #7
    Quote Originally Posted by mrbigsea View Post
    Is this normal for plug wear on these jet skis one year tops? Four new one a year is no big deal and I like to have my little baby running like a top.
    If your plugs lasted only one season and went bad, you have some other problem. I have 2004 15F and they last 3+ years. You need to read your old/bad plugs and find out what the root problem is on your engine. Just installing new plugs on your 15F every year is like putting a band-aid every time. If the plugs look rusty/brownish, your engine might have water leak in the exhaust.

  8. #8

    Join Date
    Oct 2010
    Location
    central Illinois
    Posts
    19
    The old plugs were looked at by the tech. He saw no unusual wear or tear. In a sense they were 3 years old. The jet ski is a 2009, we didn't buy it until may of 2010.

  9. #9
    I would not trust the tech's words too much.
    Next time keep the old plugs (if ski starts acting up only after one season). Take pics and post them here. Some of us can give you feedback what might be wrong with them and lead you to the right direction.

  10. #10

    Join Date
    Oct 2010
    Location
    central Illinois
    Posts
    19
    I still got them.......take the pic's and see what you folks think.......

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How To: Spark Plugs... Many pics and details
    By Shibby1485 in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 07-18-2013, 05:17 PM
  2. How-To: Spark Plugs
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 9
    Last Post: 01-23-2009, 05:16 PM
  3. Spark plugs... pictures of old and new, Normal?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-08-2005, 10:12 PM
  4. Where to buy spark plugs??
    By mgo7483 in forum 4-Tec Performance
    Replies: 33
    Last Post: 07-08-2005, 07:44 PM
  5. Spark Plug gap??
    By Cutter in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-07-2005, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •