Results 1 to 3 of 3
  1. #1

    95 slt 750 broke rod today

    so carbs were done , lines all new, fuel pump upgrade. Lost PTO rod. Usally culprit ???

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Are you asking what may have caused it?

    Prob lack of oil.

    Check your oil hoses (particularly the PTO one in your case)

  3. #3
    No cracks in hose, stiil in place. I hoped with the fuel sys upgrade a good wash I was home free, now im just home.When I did the upgrade I did a mental coin toss . Guess I lost.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Im going to look at a95 750 SLT 3 seater today!!
    By gorey in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-18-2009, 07:13 PM
  2. I broke my Mod Cherry Today!
    By Erikfar in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 03-14-2009, 11:22 PM
  3. broke 80 today
    By speedy in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-19-2008, 09:56 PM
  4. Kerry broke 96mph today!
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 11-01-2006, 01:49 PM
  5. I broke my rideplate extension today
    By Green Hulk in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-08-2005, 08:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts