Results 1 to 8 of 8
  1. #1

    Towed Waverunner now not working

    I've heard that if you towed the waverunner you can get water into your engine. The problem is I heard that after I did it. Does anybody know how to get the water out of your engine? What's the next step to getting it up and running again?


  2. #2
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,805
    +1
    2,024
    Pull the plugs & crank it to blow the water out. Once you get it started, go run the snot out of it to make sure all the water is out & everything gets lubed.

  3. #3
    I would pour 2 cycle oil directly to the cylinders and then crank it. Its going to be a mess. Then run it.
    Dont wait too much, corrosion will start very soon if the water is not removed.

  4. #4
    Crank it without the spark splugs at first

  5. #5
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    Wow glad I saw this thread! Was planning on towing mine with my pontoon or nautique.

  6. #6
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    If you need to tow it, pinch off the cooling water hose from the pump with a pinch off pliers. Some people install a ball valve inline so they can shut off water flow.

  7. #7
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    Quote Originally Posted by Cutlass View Post
    If you need to tow it, pinch off the cooling water hose from the pump with a pinch off pliers. Some people install a ball valve inline so they can shut off water flow.
    Also put your key in the engine compartment somewhere by the pliers. That way you won't forget to un-clamp the hose...

  8. #8
    brad_720's Avatar
    Join Date
    Sep 2008
    Location
    Dallas
    Posts
    65
    Quote Originally Posted by Goliath View Post
    Also put your key in the engine compartment somewhere by the pliers. That way you won't forget to un-clamp the hose...
    Now THAT is a good idea.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 02-22-2014, 05:39 PM
  2. Replies: 8
    Last Post: 10-03-2011, 11:50 PM
  3. speedo not working
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-09-2005, 06:41 AM
  4. okay, not work safe. Grossest picture I've ever seen...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-19-2005, 09:31 PM
  5. Speedometer Not Working
    By jack in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-25-2005, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •