Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Join Date
    Jul 2011
    Location
    blaine,mn
    Posts
    26

    94 polaris slt 750 stalls

    ok so after i put in a new piston and battery in the ski i took it out this weekend and it idled a little low around 900 so i turned it up to around 1100 at idle. then when i get on the throttle it seems to hesitates then goes and after about a min or two it bogs down and then dies but after a few seconds you can start it back up. then if you get on it again it does the same thing again. if you are on 1/2 throttle it runs fine for awhile then when you make a turn it stalls out again. so i am lost but i have some thoughts on what it could be, 1 is it might not be getting the gas it needs or it is getting to much. 2 is that the air/fuel/oil mix is off. i dont know how much oil i should be going through per tank of gas but i went through about 1/2 a tank and my oil didnt seem to go down at all. is there a way to test for that? i have the new 3 outlet fuel pump, new lines and have removed the auto cock.


  2. #2

    Join Date
    Jul 2011
    Location
    blaine,mn
    Posts
    26
    also if there is anyone close to blaine area that knows a 1994 slt 750 well that could help me out please let me know i would really be greatfull to any and all help

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Did you do the fuel system upgrades?

    Most likely the cause of the failed piston in the first place.

  4. #4

    Join Date
    Jul 2011
    Location
    blaine,mn
    Posts
    26
    yes i have done all fuel upgrades to the ski. new hoses, 3 outlet pump, removed the autocock, checked the fuel selector switch, did the tank venting,

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Carbs rebuilt?


    Restrictor re-installed in return line?

  6. #6

    Join Date
    Jul 2011
    Location
    blaine,mn
    Posts
    26
    carbs were done but i am not sure about the restricor was or not cause the owner before me did the lines how do i check for that and were would it be

  7. #7
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    The restrictor was typically installed immediately after the PTO carb in the fuel line. If you can't see it, the only way I can think to check is to remove the return line from the carb and the fuel tank and get some compressed air through the line. The restrictor is a very small opening and will definately slow air flow. If it seems to blow free - no restrictor.

    My setup did not have one so I had to install - hopefully someone can better describe what it looks like if it is present....

  8. #8

    Join Date
    Jul 2011
    Location
    blaine,mn
    Posts
    26
    thanks and if it doesnt have one then where do i get one or can i make one

  9. #9
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    "Tap 1 end of a 1/4in barb fitting with a m5 x 0.8 tap then screw in the apropriate mikuni main jet for your setup." previously posted by btldigger.

    The tap is not easy to find. Cost me about $15 including shipping. I made an extra restrictor with a #90 jet that I can sell to you if you need it. PM me if you are interested. Otherwise, they are pretty simple to make......

  10. #10

    Join Date
    Jul 2011
    Location
    blaine,mn
    Posts
    26
    how do i know the size i need

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 94 Polaris SLT 750 Restoration Project
    By policano in forum Polaris Projects
    Replies: 16
    Last Post: 05-30-2012, 08:08 PM
  2. 94 Polaris SLT 750- No Electrical Power
    By policano in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-11-2012, 10:11 PM
  3. 94 Polaris SLT 750 Rebuild - Carb Tuning Help
    By BlueFishCrisis in forum Polaris Projects
    Replies: 2
    Last Post: 09-05-2011, 07:53 PM
  4. 94 polaris slt 750 hull + extras north florida..
    By nick34 in forum Polaris Classifieds
    Replies: 3
    Last Post: 08-28-2009, 05:19 AM
  5. 94 Polaris SLT 750
    By Yammerhead in forum Polaris Open Discussion
    Replies: 27
    Last Post: 09-19-2008, 02:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •