Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 47
  1. #1
    rxp747's Avatar
    Join Date
    Oct 2006
    Location
    canastota, ny
    Posts
    61

    Rxp stage 3++ only turning 7200. Any ideas??

    New rebuilt top end. Cam timing is on time. Plugs are pretty black. Don't have any extras but am going to try new ones in the am. I don't gave an air intake on the supercharger yet. One on the way. Just was taking it out for a secto make sure all is good. Can only turn 7200. Everything appears to be in tact but no power. Any ideas??


  2. #2
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    boost leak

  3. #3
    rxp747's Avatar
    Join Date
    Oct 2006
    Location
    canastota, ny
    Posts
    61
    All the intercooler piping is tight. Can't really think of a leak anywhere else that I would lose that much power

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Please list all your mods and year of the ski.

  5. #5
    rxp747's Avatar
    Join Date
    Oct 2006
    Location
    canastota, ny
    Posts
    61
    04 rxp. Rr cam rr intercooler b kit Sc w spacer and mark underwood blade rise and rate 50lb injectors riva intake manifold kit rotax ported head and lightened valves rr racing computer rr modded waterbox

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Has it ever turned the correct RPM? With the RR ECU make sure you remove the knock sensor pigtail if installed.

  7. #7
    rxp747's Avatar
    Join Date
    Oct 2006
    Location
    canastota, ny
    Posts
    61
    I have had that computer in before and it was always fine. Where is the knock sensor located? Maybe it got hooked back up when I put it back together. Would I get a check engine light though if it was that?

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Try new spark plugs. What was added to the ski since it ran good.

  9. #9
    rxp747's Avatar
    Join Date
    Oct 2006
    Location
    canastota, ny
    Posts
    61
    Alot has been added to it since it last ran unfortunately. Cam, different Sc, rise and rate. Where else should I look for aboost leak that would make it this bad

  10. #10
    rxp747's Avatar
    Join Date
    Oct 2006
    Location
    canastota, ny
    Posts
    61
    Could it be doing it from running no air intake on it? I tried running it with the seat off but it made no difference

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Change paint of my RXP 260 - any ideas? stage 3
    By sebastian.pl in forum Sea Doo Build Threads
    Replies: 3
    Last Post: 10-06-2013, 12:49 PM
  2. my rxp-x will only turn 7660 rpm????
    By chays in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-15-2009, 07:40 AM
  3. 04 stage 1 RXP only turning 7900 RPM
    By fcs1965 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-22-2009, 08:52 AM
  4. RXP only turning 7500 rpm ????
    By joeschoonover74 in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-29-2007, 07:43 PM
  5. Any idea what speed I should be turning?
    By Yellow93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-25-2006, 10:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •