Results 1 to 6 of 6
  1. #1

    need advice gp1200r

    I just bought a 2001 gp1200r. When I accelerate the ski seems to run ok it just doesnt pick up speed. when the ski get on top of the water it grabs and takes off. while the ski is on top of the water I can decelerate and take off with out any problems. I was thinking it could be the impeller cavitating. Is this common or normal? If and when I pull the impeller out what kind of after market parts can I buy to make the ski faster or better acceleration. If you could recommend a part please let me know what that part does exactly in relation to the ski and why its better. I am new to the aftermarket end of the waverunner world so I am not sure what exactly these parts do ie. deep intake grate. There also seem to be so many different kinds, which one is better and why?

    Thanks so much for the help and advice


  2. #2
    Wake junky Gp1200R's Avatar
    Join Date
    May 2010
    Location
    Texas
    Posts
    136
    +1
    2
    Gpr are known for cavitation so bust out the checkbook for scoop style intake grate, impeller ,ride plate and seal pump shoe. That should be a good start. Look here in the classifieds a 13/19 impeller would be your best bet . Oh and some advice since I just bought two GPRS last year and im currently building both motors already!!! Check oil lines or better yet convert to premix as oil lines are prone to coming off. Good luck

    Nate

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to the forum

  4. #4

    Join Date
    May 2010
    Location
    Tampa, Florida
    Posts
    20
    If its cavitating, you should be able to hear it. If you hear the engine rev up but your not going anywhere then its cavitating. I would also recommend going to a premix set-up because the oil pumps are known to stop working out of no where. And welcome to the forum

  5. #5
    Wake junky Gp1200R's Avatar
    Join Date
    May 2010
    Location
    Texas
    Posts
    136
    +1
    2
    I'm still learning so correct me If im wrong but I thought the pumps were extremely reliable but lines were to blame? Thanks

    Nate

  6. #6
    Tommy Pantsdown's Avatar
    Join Date
    Jun 2010
    Location
    Cleveland, Ohio
    Posts
    413
    +1
    11
    Check the felt strip on the backside of the pump shoe. That could cause something like that to happen. Mind as well check impeller clearance also.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice needed 2000 gp1200r (rebuilt engine)
    By cape town rider in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 01-10-2013, 01:26 PM
  2. Gp1200r engine in bits but need advice
    By Steveogpr1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-08-2011, 05:33 AM
  3. gp1200r topping at 54 - 58 mph Need advice
    By jankyxl800 in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 05-04-2010, 08:49 PM
  4. need advice on pump combo for a 2000 gp1200r
    By jeepsrdreaming in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 11-05-2009, 10:55 PM
  5. Need advice on rejetted carbs on stock gp1200r and primer kit
    By AugRemy in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-16-2008, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •