Results 1 to 5 of 5

Thread: Missing RPMs?

  1. #1
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,182
    +1
    98

    Missing RPMs?

    Setup:
    Air 81F Water 74F
    04RXP 90 hrs
    X-Charger
    Riva 3" intake
    SRX-CD-15/20R Impeller
    New wear ring


    Max RPM is 7850, no slip issues or boost leak (all T-Clamps)
    Pulls hard to 7850 then just stops climbing
    No difference if full or empty fuel
    No differnce with or without BOV
    No differnce if oil is halfway between marks or full.
    Did turn 8100 with "green Wheel" and stock prop.
    Speed is just over 70, (No GPS sorry) but its a tad faster than it was with the green wheel.

    Only thing not changed is plugs but it seem to run fine no miss, the have about 30 hrs on them

    So is this about right for the setup? Is it just overpropped? No going to external intercooler cause not hacking up exhaust and hull to do it.


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    Go external intercooler-- over proped otherwise.

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Are you running the stock 38lb injectors? Pull the sock of the air filter/screen and do a run. I would get that prop depitched or get a 14/19R, if don't want to do anymore mods. The 15/20 depitched may help on holeshot, less cavitation. Getting it to turn 8100 again will make the ski feel faster and be faster than when you were running the green wheel and stock prop.

  4. #4
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,182
    +1
    98
    Quote Originally Posted by jp1300r View Post
    Are you running the stock 38lb injectors? Pull the sock of the air filter/screen and do a run. I would get that prop depitched or get a 14/19R, if don't want to do anymore mods. The 15/20 depitched may help on holeshot, less cavitation. Getting it to turn 8100 again will make the ski feel faster and be faster than when you were running the green wheel and stock prop.
    Injectors, Tried with the 38's and 42's, exactly the same RPM's No difference.

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You just need to depitch a tad bro.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I found my missing rpms....check out these pics!
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 58
    Last Post: 07-16-2007, 06:40 AM
  2. Missing RPM's?
    By ARNYGOLLOTT3 in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-30-2007, 01:41 PM
  3. Replies: 25
    Last Post: 04-17-2007, 10:13 AM
  4. Found my missing RPM`S 74mph plus now
    By CRS in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-29-2006, 03:42 PM
  5. Missing RPM???
    By TxTele in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 04-18-2006, 10:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •