Results 1 to 7 of 7

Thread: Limp Mode?

  1. #1

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113

    Limp Mode?

    I recently acquired a 1996 SL 780 that could possibly be in limp mode.I bought this ski like this very cheap. Could someone please explain how the limp mode works? The fuel level on the ski is very low and the oil level is very low also. Could this make it go in limp mode? Is there a way to tell on the dash display if its in limp mode?
    Also, how do you hook this ski up to a hose to run it on the trailer? I cant find a hose connection anywhere. I had an SL650 that had a connection for this but nothing on this ski.
    Also the digital display seems erratic, is there a way to reset it?
    Thanks for any help...


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    If you are low on fuel or oil, and the MFD light is blinking its most likely in limp mode, if the ski has it.

  3. #3

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113
    Where exactly is the MFD light located?

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Its a bright red LED right in the top center of the display

  5. #5

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113
    Thanks I will check it out. Any body know where to hook a water hose to this ski so I can run it on the trailer? Thanks again...

  6. #6
    RLACEMAN's Avatar
    Join Date
    Aug 2011
    Location
    Random Lake WI
    Posts
    884
    +1
    54
    The way I hook my Polaris to the hose is to removed the water supply hose from the rear of the inside of the boat, get a female garden hose end 3/4 size from the hdwe store & clamp that to that hose, connect garden hose to that, its not too difficult. Also if your MFD's display is not legible, sometime the red blinking light still works & by filling the fuel & oil at least 1/2 to see if the red light stops blinking. If that doesn't take it out of limp mode you have to open the electrical box & remove the gray wire from the CDI & tape it up, then it can't go into limp mode.

  7. #7

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113
    Thanks for the help, I will try all of this...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp mode on a 97 STS.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-29-2009, 07:43 AM
  2. limp mode solutions/ suggestions on 95 slx
    By slxcrazy in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 05-06-2007, 10:39 PM
  3. gas level limp mode ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-22-2007, 06:58 PM
  4. limp mode
    By tommy33mac in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-21-2007, 09:23 PM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •