Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37

    07 rxp stock ic profile ring

    i just noticed im missing the tb side profile ring that goes around the ic. i took the ic out to check it for leaks and it grew some legs and walked off. can i run it this way ? if not does anyone have one to spare thanks


  2. #2
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    hoping to have both skis out for labor day. ps i love the vts on the rxp but my gtx just walks all over it when racing. the rxp is a fun ride though

  3. #3
    Melbourne (AUS) gtile04's Avatar
    Join Date
    Apr 2009
    Location
    Melbourne
    Posts
    567
    +1
    12
    check inside ur intake box i lost mine and it was in there

  4. #4
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    Quote Originally Posted by gtile04 View Post
    check inside ur intake box i lost mine and it was in there
    yeah double checked its not in there is it safe to run it with out that ?

  5. #5
    Melbourne (AUS) gtile04's Avatar
    Join Date
    Apr 2009
    Location
    Melbourne
    Posts
    567
    +1
    12
    i would think you should be ok but it is there for a reason

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by mikelytle1077 View Post
    i just noticed im missing the tb side profile ring that goes around the ic. i took the ic out to check it for leaks and it grew some legs and walked off. can i run it this way ? if not does anyone have one to spare thanks
    I might have one. Let me look tomorrow.

  7. #7
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    Quote Originally Posted by skoepp View Post
    I might have one. Let me look tomorrow.
    thanks skoepp i had the ic to check for leaks and bingo i lost it go figure. i ran it today seemed fine but i would like to put one back in it let me know thanks

  8. #8
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Do you have any squirel's they like those rubber things I fought one off the other day it had my kanaflex house going up a tree

  9. #9
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    maybee i leave my garage open a lot. im just worried the ic wont cool right without that ring sealing it to the tb. seems fine

  10. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    809
    Quote Originally Posted by shrabber View Post
    Do you have any squirel's they like those rubber things I fought one off the other day it had my kanaflex house going up a tree
    LMFAO

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what do i need to run a x charger on an 07 rxp stock ecu?
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-27-2011, 09:09 AM
  2. RXP Stock IC Modding?
    By snowrunner in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-10-2011, 08:14 AM
  3. FS 07 RXP stock
    By developerjj in forum Sea Doo 4Tec Skis
    Replies: 10
    Last Post: 02-21-2010, 09:40 PM
  4. 07 rxp stock ecu on 08 stock rxp-x?
    By camar0 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-12-2009, 03:27 PM
  5. fs: 07 RXP Stock ECU
    By camar0 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-19-2009, 08:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •