Results 1 to 7 of 7
  1. #1

    97 XP, wont run, popping...

    my brother in law was going across the water and the ski cut off, crunk right back and would run for a minute and then cut off. We towed it back and now when you crank it it runs rough and pops through the exhaust, almost like a timing problem.

    Any ideas?


  2. #2
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    This might not be it. But sometime the brass gear in the center of the motor that turns the rotary valve will get strip out. knocking off the timing on the rotary valve. Check for metal shaving in the oil tank.

  3. #3
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Quote Originally Posted by 20 feet Boy View Post
    This might not be it. But sometime the brass gear in the center of the motor that turns the rotary valve will get strip out. knocking off the timing on the rotary valve. Check for metal shaving in the oil tank.
    +1 i'd check the rotary gear

  4. #4
    There doesnt appear to be any metal in the tank.

    I pulled the small oil lines off the pump, should i be able to pump the throttle and get oil out of there? Also, what all does the oil sensor actually read, the oil light came on last week when it had a full tank of oil.

    This morning the jet ski wont start at all unless you shoot fuel into the carbs.

  5. #5
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    Click image for larger version. 

Name:	Image.jpg 
Views:	95 
Size:	57.2 KB 
ID:	252104There are two oil lines one to the pump that feed oil to the rotary valve cover under the carbs and one that flow threw the middle of the motor and back to the oil tank lubing this shaft. If the brass gear [15] is strip you will have to tear the whole motor down. Try to see if these lines have brass shaving in them.It will save you from having to take off the rotary valve cover.The easiest way is to take the carbs off and pull the rotary valve cover and see if the shaft coming out of the motor it spin with the motor. Taking the spark plug out turn the fly wheel by hand to see if the rotary valve is spinning. It might still spin because of skipping a tooth on the gear or maybe only a few tooth are missing. I have never had this happen to me. So i am not sure if this is the problem. But I have read enough to known this happen sometimes. Try to find some kind of indication of this be fore tearing it down.

  6. #6
    Thanks. im just really trying to rule out all other options before pulling the motor.

  7. #7
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    Maybe take the magneto cover off to see if it has come loses making it spark timing wrong. But I don't think it has adjustment like some motors. MAKE SURE TO TAKE THE BATTERY OUT SO IT DOESN'T FRI ANY THING. I was all so thinking If you pull the rotary valve cover off and set the mag piston at top dead center. You could put a degree wheel on it to see if it is off or jump some tooths.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 xp wont run right need help
    By !mr!sick!nasty! in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-05-2011, 05:47 PM
  2. 97 XP Wont Crank! !HELP!
    By shavedupsdime in forum 2-Stroke Performance
    Replies: 22
    Last Post: 03-12-2010, 09:11 AM
  3. help 97 xp wont run
    By garylkendall in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-20-2009, 05:12 PM
  4. help, 97 XP not running right.
    By located_in_MI in forum 2-Stroke Performance
    Replies: 10
    Last Post: 07-06-2009, 11:53 AM
  5. 97 xp wont start need help
    By 2stroker in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-08-2008, 10:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •