Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 50
  1. #1

    Are these marks cause for concern?

    Question for the more knowledgeable. I have just over 30hrs on my 300x, all offshore. Recently I noticed a strange little mark on the exhaust manifold and the edge of the hull right next to it, the mark shows that the two came together at some point. My question is when did this occur? Did it happen during the build process at the factory when the manifold was installed? Or is the hull flexing, allowing the manifold to make contact during riding? I was able to look at another riders 300x that rides offshore on a regular basis as well and his ski had the same marks in the same places. My ski has been great so far, just wondering if this is cause for concern or nothing to worry about.


    Click image for larger version. 

Name:	IMG_20110904_190049.jpg 
Views:	113 
Size:	58.4 KB 
ID:	252007Click image for larger version. 

Name:	IMG_20110904_190030.jpg 
Views:	106 
Size:	51.5 KB 
ID:	252008


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Looks like the hull is flexing quite a bit. I don't recall seeing it on mine. I'll have to look next time.

  3. #3
    Quote Originally Posted by FIRE0021 View Post
    Looks like the hull is flexing quite a bit. I don't recall seeing it on mine. I'll have to look next time.
    We ride the same water, I'm very curious to find out if yours is doing it too. I meant to look at your ski.

  4. #4
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Mine is all cracked, I guess bad landing flex the hull?

  5. #5
    Quote Originally Posted by Olomana View Post
    Mine is all cracked, I guess bad landing flex the hull?
    Now that is interesting. In the exact same spot as the photos posted?

    I wonder if this is just common with most 300x out there. Curious to know if this only effects rough offshore riding or all types of water.

  6. #6
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Quote Originally Posted by OC_JAX View Post
    Now that is interesting. In the exact same spot as the photos posted?

    I wonder if this is just common with most 300x out there. Curious to know if this only effects rough offshore riding or all types of water.
    Exactly the same spot.
    Is the Eaton heavier than the previous SC?

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    well its not going to happen in flat water is it

    Quote Originally Posted by OC_JAX View Post
    Now that is interesting. In the exact same spot as the photos posted?

    I wonder if this is just common with most 300x out there. Curious to know if this only effects rough offshore riding or all types of water.

  8. #8
    Quote Originally Posted by nicjak View Post
    well its not going to happen in flat water is it
    Dunno yet, thats why I posted it, to find out who its happening to and when. More input from others will help determine.

  9. #9
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by Olomana View Post
    Exactly the same spot.
    Is the Eaton heavier than the previous SC?
    Lighter

  10. #10
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by nicjak View Post
    well its not going to happen in flat water is it
    Corey I could possibly see in cc this flexing as much if not more.Then offshore I think that might of been the other type of riding he was talking about But yea in flat flat water def not gonna happen.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cause for concern?
    By Sfrrob in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-01-2016, 03:04 PM
  2. Is this cause for concern?
    By Sfrrob in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-24-2016, 08:22 PM
  3. What are these bolts (plugs?) for???
    By WS6 GreeN in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-31-2013, 07:11 AM
  4. What are these two holes for? Polaris SL 700
    By tempest.runner in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-01-2011, 09:29 PM
  5. Are these good rods for a 750 crankshaft?
    By bowsniper in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-13-2010, 07:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •