Results 1 to 2 of 2
  1. #1

    Vibation help on 03" GTX 4-tec SC

    I notice at about 4k rpm's (maybe 15mph), especially when pulling my 55lbs daughter on a single tube, I get a vibration in the back hull area. Once I pass this rpm range, it goes away. It seems like it's doing it more under load, before planeing (leveling out). It's annoying and even my wife noticed it. It sounds like metal vibrating. It sounds like something in the back related to the exchaust.

    It's not terrible and may be normal. Just want to make sure.


    Thank you, Rick


  2. #2
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    its the plastic pump switch to an aluminum one theres one on ebay right now for 235.00 it will save you alot of headaches down the road with wear rings.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Advice on 2003 GTX 4-Tec SC
    By 3sgterror in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-10-2012, 04:38 PM
  2. Wired whinning noise on side of hull 02' GTX 4-tec SC
    By rickgreg in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-28-2012, 04:53 PM
  3. Need help with my 02 gtx 4-tec
    By T-DUB in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-09-2012, 08:09 PM
  4. Need Help!! 2004 GTX 4 tec SC Wont Start
    By eddyk117 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-15-2011, 08:44 AM
  5. Flat Battery on our 2002 GTX 4-tec
    By heckie in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-15-2009, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •