Results 1 to 7 of 7
  1. #1

    Problem With 96 SLT 780

    I hope im posting in the right place i just recently purchased a Polaris Slt 780! so far so good! i had to bypass the fuel sending unit with the tips i learned on this site and i really appreciate that. after running the ski this weekend it ran flawlessly until i decided to turn the Ski off to jump in the water. After doing so i tried to start it again and it didnt want to comply. i can hear a clicking in the engine like it wants to try to turn over. it did this when i first bought it and after leaving it alone for a while it starts right up ( kind of like a cold engine has no problems) however after floating aimlessly down the river for about 10 mins i decided to hit the reset switch on the electrical box and POOF it started right up! its now done this three times and the electrical switch has worked everytime! however im sure this is not right im just wondering if this is a starter issue or if i could get some direction where to start looking for the probelm


  2. #2
    Hayabusa's Avatar
    Join Date
    Sep 2006
    Location
    Trenton Michigan
    Posts
    493
    Quote Originally Posted by LtHitech View Post
    I hope im posting in the right place i just recently purchased a Polaris Slt 780! so far so good! i had to bypass the fuel sending unit with the tips i learned on this site and i really appreciate that. after running the ski this weekend it ran flawlessly until i decided to turn the Ski off to jump in the water. After doing so i tried to start it again and it didnt want to comply. i can hear a clicking in the engine like it wants to try to turn over. it did this when i first bought it and after leaving it alone for a while it starts right up ( kind of like a cold engine has no problems) however after floating aimlessly down the river for about 10 mins i decided to hit the reset switch on the electrical box and POOF it started right up! its now done this three times and the electrical switch has worked everytime! however im sure this is not right im just wondering if this is a starter issue or if i could get some direction where to start looking for the probelm
    Get out an ohm meter and check that circuit breaker/reset switch for high resistance. There's a good chance that it's no good. It can give you the same symptoms as a weak battery, only it will be intermittent.

  3. #3
    I'm assuming that it should read no resistance at all if its good?

  4. #4
    Hayabusa's Avatar
    Join Date
    Sep 2006
    Location
    Trenton Michigan
    Posts
    493
    Quote Originally Posted by LtHitech View Post
    I'm assuming that it should read no resistance at all if its good?
    Correct.

  5. #5

    Join Date
    Oct 2011
    Location
    Ontario Canada
    Posts
    203
    +1
    4
    i didnt realize they had a breaker switch . where is the location on the box ? sounds simple but im trying to pick up the basics for therse 96 fujis

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I have an open box sitting on my bench. I will post a pic later tonight pointing out what you need to find

  7. #7

    Join Date
    Oct 2011
    Location
    Ontario Canada
    Posts
    203
    +1
    4
    i found it thanks , on the back of the black box - easilly seen when the box is pulled - thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 780-starter will engage with or without lanyard-no spark either
    By shamineaukyle in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-30-2013, 08:00 AM
  2. 96 slt 780 new engine installed but problems starting
    By chazman05 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-05-2012, 09:02 PM
  3. 96 slt 780 display problems (help)
    By bbah111 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-08-2009, 10:39 PM
  4. 96 SLT 780 f/a upgrade?
    By Ibreakstuff in forum Polaris PWC Performance
    Replies: 2
    Last Post: 05-16-2007, 10:27 AM
  5. 96 SLT 780 questions
    By BBCaprice in forum Polaris Open Discussion
    Replies: 13
    Last Post: 05-14-2007, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •