Results 1 to 3 of 3
  1. #1
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1

    Picture of Center Mounted Intercooler Hoses

    I am trying to center mount a Gen II intercooler in my 04 RXP (don't like loud). Can anyone send me a picture of the stock hoses. I purchased some a long time ago, but for the life of me I cannot see how they will work. I am going to drop the engine in tomorrow, I am just trying to get my "ducks in a row" right now.


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by thompsdw View Post
    I am trying to center mount a Gen II intercooler in my 04 RXP (don't like loud). Can anyone send me a picture of the stock hoses. I purchased some a long time ago, but for the life of me I cannot see how they will work. I am going to drop the engine in tomorrow, I am just trying to get my "ducks in a row" right now.
    The longer of the two goes from SCer to the left hand side of the ICer if you were stood behind the ski, (same side the little bleed line exits the ICer) then the shorter of the 2 goes from ICer to TB on the right hand side.

    I think you may have issues with the stock 04 exhaust hose as its different in shape to the 08 exhaust hose. also the resenator is different to work with the 08 exhaust, I think you will need to get the whole 08 setup to make it work.

    Or you get the ICer fitted then make a custom pipe to get to the resenator so you can keep the noise down.

    R88

  3. #3
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    I actually purchased the different resonator and exhaust hose. My problem is, I'm not sure that I was sold the correct hoses. That's why I was looking to see if someone had a set of removed hoses they could snap a picture of for me.........

    Interestingly, last night I mounted the center mounted bracket and the lower foot (that screws into the top of the tunnel) was about 1/2" off the top of the tunnel. I made a spacer because I didn't want to stress the VTX. That was wierd........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 09-30-2011, 10:41 AM
  2. Replies: 13
    Last Post: 07-15-2011, 02:44 PM
  3. Pictures of wideband mounts on the header
    By smokeysevin in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 12-08-2009, 08:22 AM
  4. pictures of front engine mount in a 951 x4?
    By Joe Stang in forum 2-Stroke Performance
    Replies: 26
    Last Post: 12-26-2008, 02:39 PM
  5. Need a picture of where to mount this ?!?
    By UnityRacing in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-21-2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •