Results 1 to 8 of 8
  1. #1

    Join Date
    May 2011
    Location
    cary il.
    Posts
    11

    96 sl 900 cutting out in rough water.

    After many problems with drivabilty issues, i have the thing running great. Starts good, runs just under 60ish. but now an on going problem that just got way worse. When hitting hard chop (wakes) immediatly shuts down and needs to be restarted, and starts right back up. New batt, all visual elect conn look good. Any ideas are greatly appreciated.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Check your ground wire conncetions.


    Do you have the plastic cover in place over the battery?

  3. #3

    Join Date
    May 2011
    Location
    cary il.
    Posts
    11
    What other grounds besides batt ground? And only the rubber boots on the terms.

  4. #4
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    there is a plastic tray that sits on the battery before the box. This can cause a lot of problems and even burn up electronics if the battery makes contact.

  5. #5
    Red Baron's Avatar
    Join Date
    May 2011
    Location
    Belvidere, IL.
    Posts
    119
    +1
    1

  6. #6
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Check your water seperator and fuel tank,Possible when you start shaking fuel,water is getting ingested. Also check your wiring at your stop/start switch.

  7. #7

    Join Date
    May 2011
    Location
    cary il.
    Posts
    11
    Thanks guys. I found the problem. Someone took the screw out of the kill switch inside the pod, so bouncing around and hitting hard enough to turn the engine off. Strange!!! Working great now

  8. #8
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    electrical prob. can be a b--ch

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SL700 dies in rough water.
    By Paresmotorsports in forum Polaris PWC Performance
    Replies: 1
    Last Post: 06-03-2013, 07:50 AM
  2. Replies: 6
    Last Post: 05-01-2012, 05:59 PM
  3. jet ski cuts out in water
    By jpt10 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 06-17-2011, 03:01 PM
  4. FS 96 sl 900 part out
    By retro in forum Polaris Classifieds
    Replies: 2
    Last Post: 09-25-2010, 04:24 PM
  5. 96 sl 900 revs good on trailer not in water
    By turbogn in forum Polaris PWC Performance
    Replies: 1
    Last Post: 07-24-2009, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •