Results 1 to 5 of 5
  1. #1

    Polaris slx piston getting hot

    Hi there

    I have recently finished putting back together my Polaris slx 780.
    Now when it's running number 3 cylinder gets hot yet the other 2 are nice and cool.
    I have only been running it on the hose so far.

    Could it simply be that there's not enough water pressure getting to piston 3??

    Any help would be greatly appreciated.

    Ps compressions sparks etc all tested and good.


  2. #2
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    My mag cylinder on my 900 gets hot when on the hose. Try putting it in the water to see how it feels. Just leave it on the trailer in the water.

  3. #3
    Thank you

    Im gonna take it to a lake now.....

    Ill let you know how it go's, its taken a long time to get it running so hope all is ok with it.

    Cheers

    Mike

  4. #4
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Quote Originally Posted by rallyingmick View Post
    Hi there

    I have recently finished putting back together my Polaris slx 780.
    Now when it's running number 3 cylinder gets hot yet the other 2 are nice and cool.
    I have only been running it on the hose so far.

    Could it simply be that there's not enough water pressure getting to piston 3??

    Any help would be greatly appreciated.

    Ps compressions sparks etc all tested and good.
    That is very common when running on a hose. In fact, if you leave the ski strapped to the trailer at the ramp (nose high) you will get the MAG cylinder feeling hotter. The only true test for cooling and cylinder temps is on the water.

    KJ

  5. #5
    Well...
    Having placed the ski in the water, all 3 cylinders seem warm but not hot so I'm sure that's fine.

    However I have a large leak where I installed the jet pump. Grrrrr

    Probably gonna have to unbolt most of it to seal it up....

    I'll get there in the end....

    Also does the mfd display always stay on ???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Genesis engine is getting hot and locking up in the water
    By travis ingram in forum Polaris Open Discussion
    Replies: 77
    Last Post: 08-15-2012, 11:01 AM
  2. Need 1999 Polaris SLx Seat anyone know where to get one
    By K27viper in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-12-2012, 08:01 PM
  3. Replies: 12
    Last Post: 06-05-2011, 01:59 PM
  4. 1996 Polaris slx 780 unable to get it tune perfect help please
    By cubajorge2008 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 07-01-2010, 10:48 AM
  5. Polaris sl900 not accelerating once getting hot
    By oldmanbill in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 09-09-2009, 09:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •