Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Almost sank my 250X today.Now what do I do..

    Hello all, I have been a lurker for awhile but now I have something to post about.I bought a used 08 250x a couple of weeks ago it had only 13 hrs on it.got a great deal on it because it was a repo..I also have a new vxr as well and have owned other skis..I have always seen stories where someone sank a ski and thought that would never happen to me..Well I was wrong.. Im still learning about this ski and I surely learned a lesson today.We were doing a little cruising on the lakes today and while working our way through the chain on a canal I noticed ALOT of weed debis floating around,way more than usual.I actually told my wife to watch for weeds getting sucked in.When we emerged from the canal I went throttle and the ski was bogging of course I knew what it was yep the weeds I had warned my wife about had plugged me up!! So I tried to feather the throttle to clear them and it didn't work at all so I started slowly creeping while trying to find a spot to beach..I noticed alot of water in the footwells and to make this story a little shorter I had to jump off because I was going down fast..I finally made it to shallow water and pulled the seat and the engine compartment was flooded.The supercharger was submerged and it was about 3 to 4 inches from the top of the dipstick..We were able to lighten the water and my wife got on it and we proceeded on with me towing the ski.Made it back loaded drained all water.Checked oil several times and no water. Then I turned it over and it fired right up..Needless to say I was pissed at this point and thought that maybe the water got inside because it was so low in the water so I said **** IT!! and put it back in to run it and it ran good at low rpm and then sputtered when I throttled it..Filled with water again.drained it got it home and after some looking around I noticed a line had blown off from the pump I believe it had blown off at the back of the hull.it looks like there are four of them there.So I put it back on and it seem good now.I drained the oil and no water It had exactly 3.5 qts in it the same amount I put in it last weekend when I changed the oil.And it was crystal clear not milky at all.I did notice a very small amount of water in the clear tube under the airbox?? It wasn't even half full.I'm pretty certain that the weeds being caught in the impeller ultimatly blew the line off because there could have been too much force trying to get through if there was a clog?Put it on a hose and runs just like always but I'm gonna take it back in the morning and run it to be sure.I really think I got lucky today..is there anything else I need to check other than all hose connections.The supercharger belt was completely submerged.I just want to be sure I clean it as best I can..Also as a side note I just paid my insurance premium right before I took it out today..


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    if it was salt water give it a good wash with fresh water, you could check the intake for any water there is a bung at the very front of the inlet manifold down low remove t and see if any water escapes, if none your good to go, give the motor a good soak with a water dispersant and let the seat off for a week of drying out even use an air blower to speed the drying time. and since you have been lurking go and check all your clamps throughout the engine bay even the hidden hard to get at ones just follow all rubber hoses.

  3. #3
    I know always check the simple stuff...Theres alot of "stuff" to check under the seat on this ski so I'm still learning on this thing..I did double check everything I could find on this ski..Obviously I missed one.I didn't even know it was there and it did take some time to find it once I had it on the hose.I could see water rising in the hull but it took a while to find the source.

  4. #4
    Well sounds like you dodged a bullet my friend. Water that high in the engine compartment usually means it found it way inside the engine too (via air intake). I would give the Super Charger a good fogging too. You can do a serach here for fogging procedure. It's not hard to do and worth the time. JB

  5. #5
    CJ River Rider's Avatar
    Join Date
    Jul 2008
    Location
    Central NJ
    Posts
    546
    +1
    60
    Saw your post and know how you feel. I had a similar situation last year but mine was caused by the dealer leaving off a cooling hose when doing a fuel tank recall on my STX-15F. I had a lot of water in my engine compartment but no supercharger to worry about and only a little water in the air filter intake housing. Hope everything is OK with your ski. See link below for some other good suggestions which were given to me back then.


    http://www.pwctoday.com/f124/dealer-...er-275220.html

  6. #6
    Well,I took the ski out this morning to make sure everything was O.K. and it ran great.No water in the air intake or anything.It gps'd at 63.1 which is good I guess for this time of year in FL.After I got it home I fogged the supercharger as suggested and checked the plugs and fogged the motor as a precautionary as well.Thanks to you guys for ponting me in the right direction to avoid an epic failure..Now to mod this thing a little to try to keep up with my wifes VXR.

  7. #7
    Quote Originally Posted by flashsmith View Post
    Well,I took the ski out this morning to make sure everything was O.K. and it ran great.No water in the air intake or anything.It gps'd at 63.1 which is good I guess for this time of year in FL.After I got it home I fogged the supercharger as suggested and checked the plugs and fogged the motor as a precautionary as well.Thanks to you guys for ponting me in the right direction to avoid an epic failure..Now to mod this thing a little to try to keep up with my wifes VXR.
    I wouldn't Mod it Flash. If you can afford it I would upgrade to the 300. You would have to do serious "over the moon" mods to the 250 and the ROI just won't be there. Just enjoy the 250 for what it is if you keep it. But if you surf around the site here you will see the benefits of the 300 over 250 (even the 260). JB

  8. #8
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    63 is a bit slow even for the 250. Should be around 66. 68 with a few tweaks. Timing mod, rideplate. Clean the intercooler. May have gunked up with the water problem you had.

  9. #9
    I may need to clean the intercooler because when I drained it 2 weeks ago after I got it I measured a little over 5qts but there was no oil on the blow off valve and the clear tube under the airbox was about half full.Although I did pull the return on the intercooler and checked the fins with a mirror as someone suggested and it looked clean.No oil residue on the fins from what I could see.Also I replaced the plugs with iradium ones as well.It does seem a little slow and honestly I was a little dissapointed at the performance.Theres nothing amiss with the way it runs.Smooth as can be and rpms are at 7750 WOT as they should be for stock.After fogging the supercharger and tightening everything down I ran it on the hose and it sounded like it had more vacuum than before.It sounded alot stronger. I need to look into the timing mod..

  10. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    7750 is spot on i doubt you have any issue, however do the timing it will bring a

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just sold my 04 rxp! Now what do i buy to replace it with??
    By ddlawnguy in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-28-2011, 02:05 AM
  2. went to go visit my 250X Today..
    By giguchan in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 02-02-2009, 11:59 PM
  3. OK So I have Rebuilt and Installed my Engine Now What Do I Do?
    By christian79 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-19-2007, 09:22 AM
  4. Ordered my 250X today
    By Robsauto2 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 03-07-2007, 01:14 AM
  5. Almost sank my rxp today!
    By nitro rxp in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-20-2005, 09:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •