Results 1 to 2 of 2
  1. #1

    Diplay won't read

    I have a 96 SL780. Seems to finally run good but the display kicked out and doesn't work anymore. It's as blank as though it is unplugged. There is no corrosion around it. It is definitely "clicked" in. It worked great a few days ago and now I have nothing.


  2. #2
    fixer's Avatar
    Join Date
    Feb 2011
    Location
    Mass
    Posts
    498
    +1
    20
    There is a 1/4 amp fuse in the electrical box that could be the problem. I'd start there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "Reading Key" Message & Won't start
    By Davesavvy in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 11-06-2017, 10:15 PM
  2. ROCX Members, read this!
    By Thomas in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-16-2005, 04:43 PM
  3. Look what I just won for my RXP! I think it was a steal.
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-07-2005, 09:56 AM
  4. Every 4 Tec owner should read this!
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-16-2005, 12:41 PM
  5. EVERYONE READ THIS ASAP !!!!!
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-11-2005, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •