Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    94 sl750 electrical problem

    ok i got the ski back together tonight. had to replace the stater and started Bendix. so we get everything in and tight now i have to power coming out of the started selnoid to the starter. we also lost spark. do these have anything in common? plus does anyone have a wiring diagram i could have?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29

  3. #3
    ok just got doing the restince checks all are good but the alternator coil reads 0.00. im suppose to have .6 ohms. does this mean the new stator i just put in is bad?

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Was it NEW or a used stator?

    What numbers were printed on the back of it?

  5. #5
    it was a used one i bought off ebay. never again. the wires were cut before i got it. now it this is the charging part why would i have no spark

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    First, alot of people selling parts on Ebay have no clue what they are actually selling, or what it fits.

    A stator from a 650 should not be used on a 750 or 780, yet you see it in the headlines all the time.

    That's why I asked you what numbers were printed on the back of it? If you're not going to answer our Q's we can't help you....

    To answer your original Q, having 0 instead of .6 ohms WOULD be a problem. First touch your ohm meter leads together and read what you get. Then subtract that from actual reading.

    1e. touching leads together measures .2 ohms. (very seldom does your meter actually read "true" 0)

    Then say you measured .8 ohms from the stator. Subtract the .2 from the .8 and you get .6 ohm actual reading

    Finally, the stator/magneto isn't just for the charging system. It actually triggers the CDI to send a signal to the coils telling them to spark. This is where you can adjust your timing by spinning the stator clockwise or counterclockwise.

  7. #7
    i will get the numbers when i take it out. it said it was out of a 1993 sl750. now the wires going to the CDI box ring out good. what else should i check

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    1993 750 used an analog signal just like all 650. In 1994 they went to a digital signal.

    And the boxes were different too. Did you have to modify the elec connectors in any way?


    "wires going to the CDI box ring out good" What does that mean???

  9. #9
    OK so your saying is that i bought the wrong stater. i had to cut the end off my old stater to hook up the new one. I d id the resistance checks on all the other wires and they were good. that's what i meant.

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Pretty much, yeah.

    You could prob make it work (providing it IS good) by using the 1993 SL 750 CDI and maybe the flywheel. I say maybe because we know the analog 650 flywheel will NOT work with a PRO 785 CDI conversion. So I'm guessing the 93 750 (analog) flywheel is the same.

    Best bet is to get another known good stator from a 94 or 95 750, or any 780 engine.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SL750 problems :-(
    By Slipknotanfitch9 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-05-2012, 08:49 AM
  2. 94 pro vxr 700 electrical problems
    By tillerytime in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 05-04-2010, 06:11 PM
  3. 94 750 sl electrical problem
    By bryanowens in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2008, 12:08 AM
  4. 94 SL750 electrical newbee
    By 94 sl750 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 12-08-2007, 12:40 PM
  5. Electric Fuel Pump 94 SL750
    By Neal Van in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-30-2007, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •