Results 1 to 2 of 2
  1. #1

    Join Date
    Mar 2010
    north carolina

    rear seal problems

    i have a 95 raider 1100. just recently i purchased a lower end from someone. new piston kit the raider ran fine. bout ten hours later the rear seals had blew out cause no vvaccuum sloowing engine to run poorly. well i removed engine and placed two new seals in and install tha red loctite torqued and everything coorrectly. now 10 hours later once again i can see a small portion of the rear seal showing. everything is stock accept some boyenseen reeds and a primer kit. could it b backfiring or a warped crankshaft? any assistance would be great removing engine over and over gets old lol

  2. #2
    Any chance you are getting blow by in the cylinder which is causing the crank case to pressurize? Have you check compression on it?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear seal
    By stickshift69 in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-03-2010, 11:22 AM
  2. rear oil seal
    By fivespeedsteed in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 08-22-2010, 06:58 PM
  3. rear main crank seal
    By flyin4stroke in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 08-10-2007, 02:28 PM
  4. rear main engine seal
    By nonvtecdaturbo in forum Polaris Open Discussion
    Replies: 12
    Last Post: 04-18-2007, 05:49 PM
  5. 1050 97 rear seal
    By winterstick in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-15-2007, 12:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts