Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140

    Bilge Outlet below rub rail

    Can anybody explain why this thru hull fitting is below the rub rail?

    http://cgi.ebay.com/ebaymotors/ws/eB...3558+&viewitem=


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Its a drain from under the handlebar pod.

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Gotcha - thanks

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    That is not stock, and whatever it is,I'd hope the hose never fails.

  5. #5
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Acutally Danno, it is stock. The '92, '93, and '94 SL hulls had a thru-hull fitting in that location. The Pod under the guages had a bucket that drained into a hose that connected with that fitting.

    KJ

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by johnsonmtz View Post
    Acutally Danno, it is stock. The '92, '93, and '94 SL hulls had a thru-hull fitting in that location. The Pod under the guages had a bucket that drained into a hose that connected with that fitting.

    KJ
    Posting says its a 97???

  7. #7

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by BlueFishCrisis View Post
    Posting says its a 97???
    thats no 97 i would say 95

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Im pretty sure thats a 94. I had one just like it.

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Quote Originally Posted by BryanP View Post
    Im pretty sure thats a 94. I had one just like it.
    X2

  10. #10
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Quote Originally Posted by BryanP View Post
    Im pretty sure thats a 94. I had one just like it.
    Could be a '94 or '95. Factory color code for '94 is Rubine Red/Purple and '95 is Purple Velvet/ Rubine Red. '95 was the last year for the SL650.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Crazy rub rail idea
    By absentx in forum Polaris Open Discussion
    Replies: 13
    Last Post: 09-02-2006, 12:38 PM
  2. who could get the rub rail
    By RXPNJ in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-13-2006, 07:07 PM
  3. black rub rails
    By rxpblast in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 01-20-2006, 11:49 AM
  4. hydro turf..removal of rub rail
    By titi0314 in forum Yamaha How To & FAQs
    Replies: 10
    Last Post: 01-08-2006, 10:39 AM
  5. SeaDoo rub rails?
    By Pee2xUSee in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-22-2005, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •