Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    so I bought this POS ski from a member of this board... help me diagnose the issues.

    I bought a 2007 RXP from a member of this board. He claimed that everything worked perfectly and it had no issues... Which it did work perfectly for about 1 hour. Now I'm dealing with headaches.

    2007 RXP
    fizzle intercooler
    kanaflex 4" front air intake
    42 lb. injectors
    upgraded supercharger wheel
    different impeller
    different sponsons
    through hull exhaust
    umi handlebars/finger throttle
    probably a few things I'm leaving out.

    The first problem was with the VTS. When you adjust it all the way down, it get's stuck. Easy solution...leave it in the middle. Expensive solution...replace the bad parts...$500.

    Next, I switched from the rear air set up to the front air set up so that I had less chance of ingesting water... $200. After switching I lost about 300 rpms, so now the ski will only turn about 7800 rpms. I checked and double checked all of the connections and everything seems to be tight. Any insight would be appreciated.

    Then I started noticing that when I would go WOT, I would get fucking shocked. Obviously there is a bad ground or some exposed wire somewhere. I think I fixed that issue by wrapping a bunch of electrical tape on all wires leading to the handlebars, but I'm not positive.

    Then the aftermarket bilge pumps quit working. That was an easy fix. Some genius wired 2 2.5 amp bilge pumps up and used a 3 amp fuse. I replaced the 3 amp fuse with a 5 amp fuse and they now seem to be working.

    Finally, after the bilge pumps quit working I started noticing a bunch of water was leaking into the hull. Water basically fills the hull if I ride aggressively. Water doesn't come into the hull while I'm just floating, but as soon as I start getting on it water enters the hull. I've tried sealing some areas that I thought might be the culprits with epoxy and gaskets, but I've had no luck so far. After sealing the hull better I was greeted with a PO 116, which I'm not sure if that is because of the heat staying in the hull or just an issue that is always going to happen to Sea Doos.

    The water thing has me most concerned. Where should I begin looking? It has something to do with the moving parts on the ski, but I'm at a loss. Thanks for any help.


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    First thing I would check for the water coming into the hull is the bailer check valves. If they are laying In the bottom of the hull it will cause water to come in from the pump. They need to be secured up high. They look like 90 degree elbows with clear tubing.

  3. #3
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    replace carbon ring thats where the water coming from

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Wow man, did you realize you where buying a USED ski? I mean, the worst I see happening is the p0116 code which is that you have a faulty engine temp sensor. But the rest are very minimal, especially the intake thing.

    Going back to the p0116 code, does your engine run open loop?(does it run coolant or not)

  5. #5
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Get a factory service manual

  6. #6
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Oh and your water in the hull can be from a bad carbon ring, motor unaligned or broken motor mount.

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    bro, most of the issues you are describing I would not deem the fault of the seller.

  8. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    You will also loose rpms from heat and humidity and not having the correct pitched prop

  9. #9
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    And you can pick up a working vts for much less than 500 bucks

  10. #10
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Boy I wish I had you problems I replaced everything but the hull on my 2006 with 49 hours.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Someone please help me diagnose this noise?
    By jbizub in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 09-02-2013, 07:01 PM
  2. help me understand the cooling system and this diagram on our 4 tecs..
    By wisconsin_quat in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-11-2009, 04:48 PM
  3. Help me diagnose this..
    By pottzr in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-27-2008, 05:38 PM
  4. Help me diagnose this..
    By john07ex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 04-22-2008, 08:35 PM
  5. Bought this from someone, I forgot who........
    By peteshauling in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 10-20-2006, 05:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •