Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4

    Video of Shibby's RXP 1st "water test"

    first time my RXP has touched the water.... wanted to check for leaks, fluids, proper running, etc... i went from having an empty hull to fully modded machine with almost everything short of an EMS kit... so i'm hesitant to go test and ride it by myself since water temps are nearly 40 degrees and NO ONE is out there to help if i needed it and so many parts went into it all at once...

    so here's a video of how it sounds and of the ski running in the water tied to the dock... i let it float for like 20 minutes checking for leaks, then let it run for about 20 minutes checking for anything else out of the norm...

    have one minor thing to fix 2nite, and i'm planning on taking it for a ride tomorrow

    http://youtube.com/watch?v=M7ASck46qZg


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,071
    +1
    790
    Steve, just wait until you ride it. That IC is gonna BE very nice. It is gonna knock your socks off. I love mine! Looks as if you had a little water leak. Looks very nice.
    You have done a great job bro. Congrates.

    B-kit installed?

    .

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    b-kit
    RR valvetrain
    RR ECU
    fuel controller and 50#
    mild port job
    rotax racing waterbox
    intercooler

    and some other stuff here and there

    ... still need camshaft

    about fed up with closed loop and thinking of going open loop right now...

    yep... small water leak, but i know where it is, gonna fix that 2nite

  4. #4
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    Nice flannel, oh yeah the ski sounds nice too!

  5. #5
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    sounds real good. thinking of doing the same.(hitting the lake....alone....in a flannel.....in the middle of winter......to hear her run)

  6. #6
    Very nice Steve! Hope you see some good numbers now.

  7. #7
    Yamaha tow boat RIDEALLDAY's Avatar
    Join Date
    Feb 2006
    Location
    Texas
    Posts
    1,447
    Looks good, Sounds good, Ready for a 42 degree ride
    Man that's cold !

  8. #8
    JAG's Avatar
    Join Date
    Feb 2006
    Location
    Richmond, VA
    Posts
    1,026
    Did you get any GPS readings? She probably went something like .002 tied up to the dock. I bet you can get more out of her if you treat her right! She's gonna be fast!!!

  9. #9
    Yo Boneweasel, nice sweats

    it sounds good steveo, what`s the idle speed, sounds alittle high!?...PR...

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    Quote Originally Posted by Pale Rider View Post
    it sounds good steveo, what`s the idle speed, sounds alittle high!?...PR...
    all the brainiacs on this site, only ONE person notices/says something about the idle good catch Andy.... yep, idle is high @ about 2000, and if u notice at the end of the clip "on land" the ski is still revving and i'm not touching the throttle... remember those Throttle body pictures i sent you? i think i sent them to you anyway... well that's the idle problem, easy fix tho, just waiting for the right moment to get it done.

    just fixed my water leak.... DMV first thing tomorrow morning to get it registered, then slap some crummy registration stickers on it, and off I go for a test RIDE ... still debating if i'm gonna break in the motor or just say the hell with it

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Holeshot video of my '13 RXP 260
    By dpracing in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-04-2013, 05:08 PM
  2. Replies: 8
    Last Post: 03-07-2011, 01:18 PM
  3. VIDEO OF 1st Annual STOMP IN THE SWAMP
    By JETSKI JUNKIES in forum Southeast
    Replies: 5
    Last Post: 12-27-2010, 06:34 PM
  4. video of my 97 xp 787 on water & trailer. what is wrong with it?
    By djpeetur in forum 2-Stroke Performance
    Replies: 7
    Last Post: 05-11-2010, 06:28 PM
  5. rxp-x video of short chambered gibson
    By hydrojunkie in forum 4-Tec Performance
    Replies: 28
    Last Post: 06-23-2008, 08:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •