Results 1 to 3 of 3

Thread: help please

  1. #1

    Join Date
    Mar 2010
    Location
    Phillipsburg kansas
    Posts
    26

    help please

    ok i took my ski out and it had power in the front end but nothing in the back in the motor was not hot or any thing but was makeing a muffle noise it sounded like my truck did when i lost a coil and a spark plug could that be the case with the ski


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    try plugs/compression test if you can. they do foul plugs straight off the trailer even worse if the gas is old, if the gas is old drain and replace it.

  3. #3

    Join Date
    Mar 2010
    Location
    Phillipsburg kansas
    Posts
    26
    i mean it was sitting for a month with out it being started i will check the plugs today and se what they look like

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  2. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM
  3. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM
  4. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •