Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22

    Just got an 03 GTX for free but engine is hydrolocked

    So yea I was suppose to help my moms friend fix his gtx, but after removing the intake elbow, 2 cups of water came out, then again when i removed the SC to TB hose. I can see water in the cylinders and there is a good bit in the manifold. What is my best option in order to get it back to running condition. Im thinking im going to have to pull the engine at the least, do i need to remove the head and/or PTO? Just looking for direction on how to approach this. I was told its had water in it for atleast 7 weeks.


  2. #2
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Pull motor pull head clean inspect parts

  3. #3
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    thats what i figured. I got the oil out (doesnt look that bad), removed the manifold (had about a gallon of water in it), got all the water out of the cylinders. Crank it over a few times to get as much water as i could. I guess now I should remove the engine/head.

  4. #4
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Yes you can reverse a shop vac for water in intake some gets in there and is a pita to drain

  5. #5
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    What were the circumstances prior to the engine taking on the water?
    Fresh or salt?

  6. #6
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    It was running earlier in the summer, the previous owner took ok care of it, but did minimal maintenance. Water is brackish, like 70% fresh 30% salt. Water got all the way up to the fuel tank, the GTX has a heat/water shield in the front for the storage area, but all the electronics and battery are mid hull. Thats on my check list too. Going to pick up a case of oil tomorrow to do some oil changes and maybe get it running some time this week. If it runs ill do a compression test to see if it bent a valve. Hopefully theres no internal damage.

  7. #7
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    what caused it to hydrolock

  8. #8
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    From the looks of it and after I have taken its almost completely apart, the hose that hooks up to the exhaust outlet came loose. Which allowed water to come in directly from the outside a well as dump water from the exhaust.

  9. #9
    Check for bend rods.!

  10. #10
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by Radja View Post
    Check for bend rods.!
    +1 hope it wasn't ran when ingesting water

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just got an aluminum jet pump 2003 GTX SC
    By jlilla815 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-18-2012, 09:21 AM
  2. Anyone got an MRD Injection for a 780 engine?
    By JGringo in forum Polaris PWC Performance
    Replies: 2
    Last Post: 04-16-2011, 08:26 PM
  3. I just got an rxpx and its having BIG problems!!!!!
    By fireman in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-21-2008, 08:24 PM
  4. Just got an lx
    By mauisurfah in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 09-01-2007, 07:32 AM
  5. I just got a TRD box for my Msx 110 04
    By f150vtx in forum Polaris PWC Performance
    Replies: 6
    Last Post: 05-31-2007, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •