Results 1 to 5 of 5

Thread: Weird Problem?

  1. #1

    Weird Problem?

    So I rebuilt my carbs and now my engine hydrolocked it self on fuel. After I rebuilt the carbs I put them back on and ran the engine for a little bit while I was adjusting them. A few days later I went to take the ski to the river and it wouldn't start. It acted like it was hydro locked. I pulled the plugs and turned over the engine and it just started spewing fuel out of the plug holes. I think it hydro locked it self on fuel is this possible.


  2. #2
    kecheme's Avatar
    Join Date
    Jul 2011
    Location
    Phoenix Az
    Posts
    208
    +1
    7
    That is very possible. You may have a damage needle and seat. Missing o-ring for the seat. Binding needle. Or some thing as simple as a clog gas tank vent.

  3. #3
    I need to find out the stock seat size for the 787 engine.

  4. #4
    kecheme's Avatar
    Join Date
    Jul 2011
    Location
    Phoenix Az
    Posts
    208
    +1
    7
    Check the tech section on sea-doo.net

  5. #5

    Join Date
    Jul 2010
    Location
    blue springs , mo
    Posts
    141
    i just use a rebuild kit from SBT or WSM they work the best and they are cheap. But change your neddle and seat orings too that is your problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP Weird Problem
    By Camy1448 in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-17-2007, 06:54 PM
  2. 99 Ultra 150 an weird problems
    By xplayer2885 in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 09-21-2006, 03:54 PM
  3. What ignition for GPR? Weird problem with R-D CDI
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-19-2006, 06:23 AM
  4. Weird problem with ski this past weekend
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-20-2006, 06:39 PM
  5. a bit of a weird problem, can I have opinions please???
    By rxp_boy in forum 4-Tec Performance
    Replies: 9
    Last Post: 11-15-2005, 01:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •