Results 1 to 6 of 6
  1. #1
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6

    Does engine need to be running when adding anti-freeze?

    I'm going to use a drill pump to push anti-freeze through the flush port of engine. Does it have to be running when I do that?

    How much anti-freeze does it usually take?


  2. #2
    JKR1300's Avatar
    Join Date
    Jan 2006
    Location
    St Louis & 6mm LotO
    Posts
    497
    +1
    6
    Disconnect a cooling hose from the head and pour in RV antifreeze. No need to run the engine.
    Pour in enough until it starts coming out of the water inlet in the pump

  3. #3

    Join Date
    Aug 2006
    Location
    Orange County, Ca
    Posts
    275
    +1
    1
    It doesnt need much your just mixing antifreeze with the water that is left inside then engine... remember to pinch the hose coming in from your pump so it doesnt come out of there when filling..

  4. #4
    xray328's Avatar
    Join Date
    Aug 2011
    Location
    Shorewood, IL
    Posts
    364
    +1
    6
    I was thinking about just using the flush hose and tilting the trailer down (So it doesn't just run out the pump)? Would that work?

  5. #5
    Superman! fivespeedsteed's Avatar
    Join Date
    May 2010
    Location
    Midlothian VA
    Posts
    1,058
    +1
    14
    you disconnect both lines off the head or just the first one?

  6. #6
    JKR1300's Avatar
    Join Date
    Jan 2006
    Location
    St Louis & 6mm LotO
    Posts
    497
    +1
    6
    Quote Originally Posted by fivespeedsteed View Post
    you disconnect both lines off the head or just the first one?
    Either hose - doesn't matter

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does the battery need to be removed when using the Battery Tender?
    By xray328 in forum Yamaha Open Discussion
    Replies: 9
    Last Post: 11-18-2011, 09:02 PM
  2. Can I Paint The Bottom Of My Jet Ski Or Does It Need To Be Gel Coat???
    By 1998PRO785HO in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 11-04-2010, 06:30 PM
  3. does this need to be glassed???
    By killcraft in forum Polaris Open Discussion
    Replies: 9
    Last Post: 03-08-2010, 04:12 PM
  4. Replies: 1
    Last Post: 06-12-2009, 08:23 PM
  5. Why does engine need to run during flushing?
    By zone 5 in forum 4-Tec Performance
    Replies: 15
    Last Post: 11-15-2008, 07:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •