Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    822

    GP1300R stumbles around 3000 RPM after revving it up out of water

    Anyone ever have a problem when the ski is out of the water, the ski idles fine, but after revving it up, it stumbles (rough idle) around 3000 RPM (2800 - 3200)? I backed it into the water at a local ramp and ski seemed to run fine. I havent taken it out for a ride yet. When this is happening, the EFI controller sporadically flashes green.

    I had the injectors cleaned and flow tested prior to this happening. I took everything apart again and reassembled it to make sure the seals around the reed assembly was assembled properly.

    One thing I am uncertain about is the grease at the base of the injectors and the O ring at the base of the injectors. When I took them out they had a red thick grease substance around the base and the O ring was inside the TB. I cleaned the grease off before taking them to get cleaned/flow tested and when I reassembled them back in I used a some dialectic grease. Also the O ring remained in the throttle body.

    I changed plugs and still have the problem.

    Any ideas?


  2. #2
    Every adventure comes to an end........ Not Today! wreckingball's Avatar
    Join Date
    Sep 2009
    Location
    San Diego, California, United States
    Posts
    1,347
    +1
    2
    Bad plug wires???

  3. #3
    HUH? the O ring should stay on the injectors, don`t use dielectric grease where injector fits into TB.
    that grease keeps the o rings soft and helps seal and keep crap out.
    The GPR will not rev freely out of the water like an automobile especially if you have a controller. The fuel/extra fuel is loading up and not being pushed out of the pipe...

    My ski will rev cleanly bc I have a R&D R1 ecu, and it is leaner at idle, so the rev is crisp...

    what you are experiencing is Normal! unless you do find an obvious issue...
    Gus> Ride more, worry less or I`m telling Jim!!! hahahahaha

    ok, you have used up my one post quota on GH... BYE...

  4. #4
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    822
    Quote Originally Posted by Pale Rider View Post
    HUH? the O ring should stay on the injectors, don`t use dielectric grease where injector fits into TB.
    that grease keeps the o rings soft and helps seal and keep crap out.
    The GPR will not rev freely out of the water like an automobile especially if you have a controller. The fuel/extra fuel is loading up and not being pushed out of the pipe...

    My ski will rev cleanly bc I have a R&D R1 ecu, and it is leaner at idle, so the rev is crisp...

    what you are experiencing is Normal! unless you do find an obvious issue...
    Gus> Ride more, worry less or I`m telling Jim!!! hahahahaha

    ok, you have used up my one post quota on GH... BYE...

    Ok, maybe it did this before and I just didnt notice? I will take it out tomorrow and beat the crap out of it. If it breaks it breaks...

  5. #5
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64

  6. #6
    Quote Originally Posted by Gus13letter View Post
    Ok, maybe it did this before and I just didnt notice? I will take it out tomorrow and beat the crap out of it. If it breaks it breaks...
    Gus do I have to come to Fla! hahahahahahaha now it`s 3 posts... happy!!!, hahahahaha

  7. #7
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    You have to put it in the water and try it, GPR'S with efi do not like to be revved up out of water some times they will even pop and act like you are not getting enough fuel.

  8. #8
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    You have to put it in the water and try it, GPR'S with efi do not like to be revved up out of water some times they will even pop and act like you are not getting enough fuel.
    +1000 hey Jim!

    Gus that 4 posts now bro your killing me! ride more worry less... Jim go straighten him out will ya paleeese!!!

  9. #9
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Make up your mind...... you said it was idling at 3000 rpm's

  10. #10
    Quote Originally Posted by L Carlson View Post
    Make up your mind...... you said it was idling at 3000 rpm's
    Lee!,
    he better fix that issue with the O rings if they came off the injectors...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 polaris sl 750 dies after running it all out for a 5-10 minutes
    By abbieg250 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-02-2012, 11:11 PM
  2. 96 Gtx, rpm's go down to 1500 out of water after idling for a while.
    By Alex3012red in forum 2-Stroke Performance
    Replies: 5
    Last Post: 02-06-2011, 08:57 PM
  3. 98 XPL, boggs after coming out of water.
    By JBradshaw00 in forum 2-Stroke Performance
    Replies: 10
    Last Post: 05-01-2009, 07:37 PM
  4. RPM Raises to 4500 RPM and higher on its own out of water
    By bj25430 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-13-2007, 12:11 PM
  5. Bogging at around 5k rpm after D-Plate + Jetworks.
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 08-08-2006, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •