Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4

    Advent in xl1200 ltd

    Has anyone had any issues with the Advent 1290 in an XL? I just installed it, and its causing a hi temp light, and warning. I talked to Greg already, and he says that he cant quite recall, but only the xl's had a problem not the gpr's. Im gonna talk to him Monday, but in the mean time, has anyone have any experience with this??


  2. #2
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    NOone????????

  3. #3

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    are your sure have dip switches set up right?

  4. #4
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    yep, Both turned off

  5. #5
    the xl and the gpr's are the same just different hulls, so i cant see that being the issue

  6. #6
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    Quote Originally Posted by ctct2118 View Post
    the xl and the gpr's are the same just different hulls, so i cant see that being the issue
    different gauge clusters, I believe thats where the problem may be....still waiting for someone with an xl and an older Advent to chime in........

  7. #7
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    I have had and installed many advents on XLL-XLT it's not the ski there is a problem with the advent, I had a GPR with the flashing temp light with a advent it was a problem with the advent.

  8. #8
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    So, Jim, youre saying the unit is bad? Is there any downfall of running the ski with the sensor the way it is? I talked to Greg, and he told me that the only option is to disconnect the two wires going to the instrument panel...will try that tomorrow.

  9. #9
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by pokplalya22 View Post
    So, Jim, youre saying the unit is bad? Is there any downfall of running the ski with the sensor the way it is? I talked to Greg, and he told me that the only option is to disconnect the two wires going to the instrument panel...will try that tomorrow.
    Yes that can be done , Is this a used unit or new if it's new why not send it back and get fixed right.

  10. #10
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    I have had and installed many advents on XLL-XLT it's not the ski there is a problem with the advent, I had a GPR with the flashing temp light with a advent it was a problem with the advent.
    Was that the one I sent 2 you?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Xl1200 ltd rebuild gone wrong! Water in all cylinders.
    By toddnbrown in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 07-23-2012, 04:18 PM
  2. 00 xl1200 ltd found small amount of metal in the cyl ???
    By chevydog in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 09-18-2011, 01:37 PM
  3. Wave Eater Clips install in XL1200 Directions? Pics?
    By kaarona1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-05-2008, 12:53 PM
  4. 99 XL1200 LTD strange problem
    By dank in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 04-03-2008, 03:42 PM
  5. Anyone Put 05 rxp motor in 02gtx ltd
    By TNTDEALZ in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-29-2007, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •