Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1

    Angry help big time upgrades got my 11 fzr 10 mph slower

    can any one shed light on the fact that by adding the following upgrades im going 10 mph slower when i should be going 10 mph faster give or take a couple of mph netting
    a loss of 20mph give or take.

    rd C1 monster sc impeller $429
    R2 ECU reprogramming $749
    solas dynofly rseries 13-22 impeller $299
    Riva perf power filter intake kit $279
    RIVA engine breather $49
    Riva free flow exhaust kit $194
    pump seal kit $79
    2 flow rite vents $20
    total $1778

    max rpm 6800
    max speed 59.2 with 3/4 tank
    i weigh 187


  2. #2
    Taking money away from the Z06 Fund
    Join Date
    Sep 2007
    Location
    Gainesville, VA
    Posts
    560
    +1
    1
    Quote Originally Posted by peterj59 View Post
    can any one shed light on the fact that by adding the following upgrades im going 10 mph slower when i should be going 10 mph faster give or take a couple of mph netting
    a loss of 20mph give or take.

    rd C1 monster sc impeller $429
    R2 ECU reprogramming $749
    solas dynofly rseries 13-22 impeller $299
    Riva perf power filter intake kit $279
    RIVA engine breather $49
    Riva free flow exhaust kit $194
    pump seal kit $79
    2 flow rite vents $20
    total $1778

    max rpm 6800
    max speed 59.2 with 3/4 tank
    i weigh 187
    Sounds like it's not making any boost, did you check for boost leaks?

  3. #3
    boost leaks? where would i check, i assume first the elbow jt outlet to inter cooler inlet, where else would i look?

  4. #4
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Running a BOV at all?? Have a boost gauge?

  5. #5
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by poof100 View Post
    Sounds like it's not making any boost, did you check for boost leaks?




    Yea boost leaks......got beat to that one

  6. #6
    no BOV kit, where can i look for boost leaks

  7. #7
    Hammy's Avatar
    Join Date
    Nov 2009
    Location
    Tahiti, French Polynesia
    Posts
    166
    Boost leak, check all the piping from the air filter to the intercooler as well. Also did you take off your ribbon ?

  8. #8
    no didnt remve ribbon

  9. #9
    i dont think the ribbon would matter im not running more the 9 or 10 pounds of boost,
    also shouldnt i get at least what stock is.

  10. #10
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,134
    +1
    205
    What are your rpms at? Probably not more than 6000 if I had to guess. Boost leak is absolutly a likely cause. Happened to me back in 2010, but my speed loss was just a few mph, not 10+

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my 11 fzr doesnt have threaded plug for AFR
    By peterj59 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 10-10-2011, 11:08 AM
  2. MSX 150 crazy stuff... need help big time
    By boomanch1967 in forum MSX/Matrix
    Replies: 17
    Last Post: 08-15-2011, 05:09 PM
  3. need help big time.
    By aquatrax1 in forum Honda How To & FAQs
    Replies: 4
    Last Post: 07-11-2011, 09:56 AM
  4. Need help BIG TIME
    By Lvnspeed in forum 4-Tec Performance
    Replies: 21
    Last Post: 10-29-2009, 09:49 PM
  5. Need Help Big time
    By loballa1 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-06-2008, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •