Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    2001 polairs virage tx 1200

    i have a 2001 polairs virage tx it start up great and idel ok but soon as you give it a little throttle it sound like it has a rev limiter on it i change the tps not sure what to do next any help would be great


  2. #2
    Check the fuel pressure.

  3. #3
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    You need 20 PSI at a minumum for the fuel pressure. If you get zero, pull the fuel pump and see if the regulator has fallen off inside the tank. It should be attached to a short section of fuel line on the underside of the fuel pump on the return line side that has the schrader valve.

  4. #4
    still having problem with 2001polairs virage tx fuel pressure is good 25psi still start good ideal good wil not throottle up not sure if it fuel or computer. any help would be great.

  5. #5
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Is this a TX or a TXI? The TX does not have a TPS or computer (EMM). Instead you have 3 40mm carbs and a CDI box.

  6. #6
    i have 2001 virage tx it has a emm and a tps it has fuel injected 3 cylinderthe red jugs

  7. #7
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Interesting. When I look up a 2001 Virage TX it shows to be a carbed 1200. The fuel injected models were the Virage I and the Virae TXI. I guess someone could have switched it over to fuel injection. Check the voltage at the red/white wires at the injectors with them plugged in. You should get about 45V DC when the engine is running. Once you shut the engine down the voltage should slowly decay to zero. If it goes directly to zero really fast the big capacitor could be bad.

  8. #8
    i found out that my used tps is bad iam trying to find a new one that should fix my problem know were to get one any help would be great

  9. #9
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Quote Originally Posted by jackofalltrades View Post
    Interesting. When I look up a 2001 Virage TX it shows to be a carbed 1200. The fuel injected models were the Virage I and the Virae TXI.
    Just another Polaris screw up. It seems they did not have any TXI decals in '01.
    They all have TX decals. The '01 TX is white/red (hood/seat). The '01 TXI is white/black (hood/seat)

  10. #10
    your right casey on my ski.still looking for a tps no luck finding one any were.try to buy new no longer available.any help would be great

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Virage tx 1200 won't start
    By dfgtye in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-23-2014, 06:28 PM
  2. 2001 Polaris Virage TX 1200 no spark
    By wrt01 in forum Polaris PWC Performance
    Replies: 23
    Last Post: 07-24-2013, 06:35 AM
  3. 2001 Polaris Virage TX 1200 cuts out wont go full speed
    By hydro rider in forum Polaris PWC Performance
    Replies: 6
    Last Post: 07-20-2013, 07:52 AM
  4. 2001 Polaris Virage tx 1200 with no spark
    By rparsons71 in forum Polaris Projects
    Replies: 3
    Last Post: 05-29-2013, 10:43 PM
  5. 2001 Polaris Virage TX 1200?
    By ftr0432 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-16-2011, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •