Results 1 to 9 of 9
  1. #1

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22

    Help with Ski RPMs

    Hi I just took my ski out. I changed the Oil and Plugs and a Fresh tank of gas. Im only getting about 5900-6000 Rpms. I have 180 Hours and Honda put a New turbo 80 Hours ago. Do you think this could be My Impeller or something with the Turbo?


  2. #2
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    If it is a three seater, that is about all it will turn, stock. A new set of plugs might get you another hundred or two. Limiter is at 6400.

  3. #3

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22
    I just put a new set of Plugs Its a 2 Seater R12X It used to run at around 6200

  4. #4

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22
    It will only go about 58-59

  5. #5
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    You might want to check your waste gate solenoid. Put a boost gauge on it tee'd into the front MAP sensor. At WOT you should have about 12.0 PSI stock.

  6. #6

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22
    I will check this tonight... Also i can see a small exhaust leak between the Exhaust and the Turbo/Wastegate is there supposed to be a gasket there?

  7. #7
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Yes

  8. #8

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22
    I had a new Turbo put in under warranty by Riva Motorsports and i think they left it out would that cause this problem?

  9. #9
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Yes 2 reasons: Loss of boost and also exhaust gasses expelled into engine compartment so less oxygen being taken in intake. If it is not this do as JAX has said and check wastegate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with 15F RPM kit performance
    By Super7Four in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 07-01-2010, 12:38 AM
  2. Any Help with Ski shipping!?? Mi to Florida! Pricing??
    By doc212121 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 10-25-2008, 11:26 AM
  3. SW missouri rider needs help with ski shipping
    By mcar33 in forum Open Discussion
    Replies: 9
    Last Post: 04-11-2007, 11:01 PM
  4. Need help with ski??
    By WVGP1200R in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 05-27-2006, 10:15 AM
  5. Help with Ski overflowing oil.
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-02-2006, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •