Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    GTX RFI almost wont start in water

    hi another issue i noticed today on my GTX RFI 2001 was the starer motor was very slow to turnover in the water, i have a new fully charged battery and new rectifier. out of the water it turns over quicker but not very quick. With the plugs out it does turn over quickly!

    It hasnt let me down starting in the water yet, but it was touch and go today it sounded like the starter wasnt going to turnover the engine.

    Given a chance the engine starts and it runs well achieving top speed.

    sounds like i need a new starter motor?


  2. #2

  3. #3
    well i dont think it is the starter motor. took it out and striped it down, looks like new and runs well on test. Installed it back on engine. I put power straight to the starter motor on the engine via a seperate car battery and it is still seems to struggle to energise and get the electric motor going, almost as though it wouldnt be able to turn the engine over. once turning over it seems ok. Is this normal?

  4. #4
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by snowsports1 View Post
    well i dont think it is the starter motor. took it out and striped it down, looks like new and runs well on test. Installed it back on engine. I put power straight to the starter motor on the engine via a seperate car battery and it is still seems to struggle to energise and get the electric motor going, almost as though it wouldnt be able to turn the engine over. once turning over it seems ok. Is this normal?

    Have you ever done a compression test. You may want to see if it turns over by hand easily with the plugs out and remove the pump and verify that it's not the cause of your problem.

  5. #5
    I have ordered a compression tester. I did remove the plugs a was able to turn the PTO using one hand without much effort. I dont know how "easy" it should be to turn. With plugs in i couldnt turn it past compression by hand.

    I havent done any work on the jet pump, but the ski goes really well on water, it could be offering increased resistance. It looks like a major job to remove this, relignment etc?

  6. #6
    can lack of grease in the PTO cause slow engine cranking?

  7. #7
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by snowsports1 View Post
    can lack of grease in the PTO cause slow engine cranking?


    If you were able to turn the engine over (plugs out) with out much effort I think, provided you are not having a cable or starter relay issue, (I saw you have a new fully charged battery) you need to think about trying a new starter. Bench testing a starter to see if it spins is not a very good test for a symptom that occurs under load. That's my opinion.

  8. #8
    I will try to upload a video of it starting then maybe you can give me your views on whether it is "normal". Any ideas how i upload a video?!

  9. #9
    redneck71's Avatar
    Join Date
    Sep 2011
    Location
    middletown DE
    Posts
    74
    +1
    8
    on my friends 99 rfi it was the the factory starter that had just had it i got one from SBT works great

  10. #10
    i have decided to buy a new starter motor, while the ski is in pieces i dont want to risk the old one. I will let you all know if it sorts out the problem.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Seadoo GSX RFI Extremly hard start in water.
    By RightsaidFred in forum 2-Stroke Performance
    Replies: 14
    Last Post: 07-16-2014, 09:01 AM
  2. 03 seadoo gti le rfi hard to start in water
    By billybullets in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-30-2012, 10:07 AM
  3. 2002 gtx rfi wont start in water
    By seadooxplimited in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-27-2011, 10:24 PM
  4. 99 seadoo gtx rfi wont start in water
    By havinfun in forum 2-Stroke Performance
    Replies: 14
    Last Post: 08-15-2010, 04:24 PM
  5. 98 GSX Wont start in water
    By hawkrdr in forum 2-Stroke Performance
    Replies: 13
    Last Post: 05-12-2009, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •