Results 1 to 2 of 2
  1. #1

    2005 stx 900no spark

    i need help i replaced the cdi with a used one still no spark how do i test it? can i send the original and new used one to someone to test on their bike or just test?
    thanks


  2. #2
    Texan78's Avatar
    Join Date
    Feb 2010
    Location
    N. Texas
    Posts
    395
    Check to make sure you have a good ground and your battery cables are not damage or properly seated. Does the ski crank at all? You can pop off one of the plug wires and see if it is arcing when you crank it. It this was a working CDI when you ordered it I would check all your wirring first. I know it seems common and you may not think there is nothing wrong but you would be surprised. Wires coming loose and looking like they aren't has happened to me many times and will make you slap your head when you relized it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki 2005 stx 1200f no spark on coils
    By Giroux in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-08-2014, 08:15 PM
  2. 2005 STX 12F No fulel or spark to #1 and 4 cylinder
    By aleskypr in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 07-15-2013, 11:55 AM
  3. 2005 STX-15F Continually needing new spark plugs
    By tylercnewport in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 06-14-2013, 02:14 PM
  4. Replies: 5
    Last Post: 09-14-2007, 04:54 PM
  5. 2005 STX 12f....no fuel
    By x2dad in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-03-2007, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •