Results 1 to 2 of 2
  1. #1
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724

    2002 DI Up and running =D

    Finished up the DI, Put 5.5 hours on it so far! First hour or so i seen 6750 rpms and now its up to 6890 with two people on it trimmed out.

    Motor seems SMOOTH and On demand.

    Compression seems a tad low though 130 per hole. Was 120 when first assembled.

    Stock bore resleeved with OEM pistons..

    Everything else seems on the money though! ANy thoughts?


  2. #2
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    Its up to 7950 rpms.. But i found the speed issue was a dinged up impeller and DEAD wear ring... So, i ordered the solas 15/20 impeller and OEM wear ring!

    Be here tommorrow from PPG =D

    Excited!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage Off and Running!!!
    By ryand in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-02-2008, 02:54 PM
  2. GH Back up and running
    By Jrsrxp in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-02-2008, 09:37 AM
  3. It's up and running!! Check it out!! Go AWA!!!
    By SeaDoocer in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 03-21-2007, 08:35 PM
  4. ECU up and running on RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-16-2006, 12:23 AM
  5. Triple back up and running
    By GPRPITMAN in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-14-2006, 04:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •